lucene-solr-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Jon Strayer <...@strayer.org>
Subject Re: 4.2.1 Tutorial
Date Tue, 30 Apr 2013 14:07:18 GMT
I haven't found that, but I did find this:

Apr 30, 2013 9:38:10 AM org.apache.solr.core.CoreContainer create
INFO: Creating SolrCore 'collection1' using instanceDir: solr/collection1
Apr 30, 2013 9:38:10 AM org.apache.solr.core.SolrResourceLoader <init>
INFO: new SolrResourceLoader for directory: 'solr/collection1/'
Apr 30, 2013 9:38:10 AM org.apache.solr.core.SolrConfig initLibs

And then this:
Apr 30, 2013 9:38:11 AM org.apache.solr.core.SolrCore <init>
INFO: [collection1] Opening new SolrCore at solr/collection1/,
dataDir=/Users/jon.strayer/solr/solr-4.2.1/example/solr/collection1/data/

And a little later:
Apr 30, 2013 9:38:11 AM org.apache.solr.core.CachingDirectoryFactory get
INFO: return new directory for
/Users/jon.strayer/solr/solr-4.2.1/example/solr/collection1/data forceNew:
false
Apr 30, 2013 9:38:11 AM org.apache.solr.core.SolrCore getNewIndexDir
INFO: New index directory detected: old=null
new=/Users/jon.strayer/solr/solr-4.2.1/example/solr/collection1/data/index/
Apr 30, 2013 9:38:11 AM org.apache.solr.core.CachingDirectoryFactory get
INFO: return new directory for
/Users/jon.strayer/solr/solr-4.2.1/example/solr/collection1/data/index
forceNew: false

It looks to me as if the core does exist (and in fact I can add documents
to it).  But for some reason parts of the system don't know about it.


On Mon, Apr 29, 2013 at 5:20 PM, Furkan KAMACI <furkankamaci@gmail.com>wrote:

> Check your logs when you startup Solr if you get that error: "There exists
> no core with the name "collection1"". Do you get any error as like
> core:collection1 could not create or something like that?
>
> 2013/4/29 Jon Strayer <jon@strayer.org>
>
> > I can't be the only person to run into this, but I can't find any mention
> > of it anywhere.
> >
> > I have Solr 4.2.1 installed under OSX 10.8.3.  I'm working my way through
> > the tutorial.
> >
> > When I click on this link:
> http://localhost:8983/solr/#/collection1/queryI get the error message
> "There exists no core with the name "collection1"".
> >
> > This link works:
> > http://localhost:8983/solr/collection1/select?q=solr&wt=xml
> >
> > What am I doing wrong?
> >
> > [image: Inline image 1]
> >
> > --
> > To *know* is one thing, and to know for certain *that* we know is
> another.
> > --William James
> >
>



-- 
To *know* is one thing, and to know for certain *that* we know is another.
--William James

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message