lucene-solr-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Jack Krupansky" <j...@basetechnology.com>
Subject Re: NPE when faceting TEXTfield in a distributed search query
Date Wed, 10 Apr 2013 22:30:34 GMT
Are you sure you want to facet on a text field??? That will facet on the 
individual terms, which isn't usually very useful.

Usually, people want to facet on full phrases or entire strings, so they do 
a schema copyField from the text field to a string field and then facet on 
the string field.

-- Jack Krupansky

-----Original Message----- 
From: coolpriya5
Sent: Wednesday, April 10, 2013 6:19 PM
To: solr-user@lucene.apache.org
Subject: NPE when faceting TEXTfield in a distributed search query

Hi,

I have a nullable TextField with field type as follows(field
name=fun_group):-
<fieldType name="lowercase_sort_missing_first" class="solr.TextField"
sortMissingFirst="true" positionIncrementGap="100">
<analyzer><tokenizer class="solr.KeywordTokenizerFactory"/>
<filter class="solr.LowerCaseFilterFactory"/></analyzer>
</fieldType>

field definition is:-
<field name="fun_group" type="lowercase_sort_missing_first" indexed="true"
stored="true" multiValued="false"/>

I am running a distributed search(using shards= param) across 13 shards
while faceting on fun_group with the following params:-

http://<shard1>/solr/mycore/select?facet=true&facet.field=fun_group&facet.mincount=1&rows=0&facet.limit=10000&facet.offset=0&q=(((my_id:4024
AND ((flag:1 OR flag:0)))) AND
class_id:2604)&shards=<shard1>/solr/mycore,<shard2>/solr/mycore,<shard3>/solr/mycore,<shard4>/solr/mycore,<shard5>/solr/mycore,<shard6>/solr/mycore,<shard7>/solr/mycore,<shard8>/solr/mycore,<shard9>/solr/mycore,<shard10>/solr/mycore,<shard11>/solr/mycore,<shard12>/solr/mycore,<shard13>/solr/mycore

I get Internal Server Error on shard6. In the logs, I see the NPE from
org.apache.solr.servlet.SolrDispatchFilter.

If I change the facet.limit from 10000 to 5000 keeping the
facet.offset=0,there are no exceptions. Now again if try facet.limit=5000
and facet.offset=5000 , I get the same exception. I tried facet.limit=4000
and facet.offset=5000, it worked fine. Please help



--
View this message in context: 
http://lucene.472066.n3.nabble.com/NPE-when-faceting-TEXTfield-in-a-distributed-search-query-tp4055172.html
Sent from the Solr - User mailing list archive at Nabble.com. 


Mime
View raw message