lucene-solr-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Erick Erickson <erickerick...@gmail.com>
Subject Re: Strange Error
Date Thu, 07 Mar 2013 17:55:37 GMT
did you re-index everything after you changed from date to tdate? Looks to
me like you had some data already in your index, changed the defs, added a
few more docs and blew up.....

I'd just blow away your entire index directory and re-index from scratch...

Best
Erick


On Tue, Mar 5, 2013 at 11:02 PM, Eric Myers <emyers@nabancard.com> wrote:

> |
>
> I am getting the following error when I try to use a stats.facet for a
> date field. Anyone know how to fix this?
>
> <str name="msg">Invalid Date String:' #1;#0;#0;#0;&#5;oT$#0;'</str>
>
> ||I have checked the values of the date and they are all fine.
> I am not sure where this is coming from.
>
> The really odd thing is that this worked fine, and then all of a sudden
> went crazy. I tried both date and tdate (it worked with date for a while).
>
> |the query string
>
> http://hidden/solr/activity/select?q=*%3A*&wt=xml&indent=true&stats=true&stats.field=amount&stats.facet=date_facet
>
> field data
> <date name="date_facet">2013-03-05T05:00:00Z</date>
>
> schema
>    <field name="date_facet" type="date" indexed="true" stored="true" />
>
>     <fieldType name="date" class="solr.TrieDateField" precisionStep="0"
> positionIncrementGap="0"/>
>     <fieldType name="tdate" class="solr.TrieDateField" precisionStep="6"
> positionIncrementGap="0"/>
>
>

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message