lucene-solr-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Mark Miller <markrmil...@gmail.com>
Subject Re: NPE when adding docs in 4.2
Date Sat, 16 Mar 2013 15:16:04 GMT
You mean replication factor of 1 not 0.

I'm cleaning up the collection api responses for 4.3 so that you would get a clear error for
this type of thing (https://issues.apache.org/jira/browse/SOLR-4494). There should be info
about it in the overseer log currently.

I think I've also already fix that cloud server call to return an message about not finding
the collection rather than an NPE (for 4.3).

- Mark

On Mar 16, 2013, at 9:47 AM, J Mohamed Zahoor <zahoor@indix.com> wrote:

> Hi
> 
> I am using Solr 4.2. I created 2 collections by using 
> 
> 
> "http://localhost:8983/solr/admin/collections?action=CREATE&name=collection1&numShards=1&replicationFactor=0&maxShardsPerNode=1"
> "http://localhost:8983/solr/admin/collections?action=CREATE&name=collection2&numShards=1&replicationFactor=0&maxShardsPerNode=1"
> 
> Now. When i try to insert the document in collection2, i get the following NPE.
> 
> java.lang.NullPointerException
> 	at org.apache.solr.client.solrj.util.ClientUtils.addSlices(ClientUtils.java:273)
> 	at org.apache.solr.client.solrj.impl.CloudSolrServer.request(CloudSolrServer.java:214)
> 	at org.apache.solr.client.solrj.request.AbstractUpdateRequest.process(AbstractUpdateRequest.java:117)
> 	at org.apache.solr.client.solrj.SolrServer.add(SolrServer.java:68)
> 	at org.apache.solr.client.solrj.SolrServer.add(SolrServer.java:54)
> 
> 
> Anything obvious i am missing?
> 
> ./zahoor
> 


Mime
View raw message