lucene-solr-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From David Parks <davidpark...@yahoo.com>
Subject Re: After upgrade to solr4, search doesn't work
Date Wed, 06 Mar 2013 07:00:08 GMT
Oops, I didn't include the full XML there, hopefully this formats ok.

<fieldType name="text_en_splitting" class="solr.TextField" positionIncrementGap="100" autoGeneratePhraseQueries="true"><analyzer
type="index"><tokenizer class="solr.WhitespaceTokenizerFactory"/><!-- in this
example, we will only use synonyms at query time <filter class="solr.SynonymFilterFactory"
synonyms="index_synonyms.txt" ignoreCase="true" expand="false"/> --><!-- Case insensitive
stop word removal. add enablePositionIncrements=true in both the index and query analyzers
to leave a 'gap' for more accurate phrase queries. --><filter class="solr.StopFilterFactory"
ignoreCase="true" words="lang/stopwords_en.txt" enablePositionIncrements="true" /><filter
class="solr.WordDelimiterFilterFactory" generateWordParts="1" generateNumberParts="1" catenateWords="1"
catenateNumbers="1" catenateAll="0" splitOnCaseChange="1"/><filter class="solr.LowerCaseFilterFactory"/><filter
class="solr.KeywordMarkerFilterFactory" protected="protwords.txt"/><filter
 class="solr.PorterStemFilterFactory"/></analyzer><analyzer type="query"><tokenizer
class="solr.WhitespaceTokenizerFactory"/><filter class="solr.SynonymFilterFactory" synonyms="synonyms.txt"
ignoreCase="true" expand="true"/><filter class="solr.StopFilterFactory" ignoreCase="true"
words="lang/stopwords_en.txt" enablePositionIncrements="true" /><filter class="solr.WordDelimiterFilterFactory"
generateWordParts="1" generateNumberParts="1" catenateWords="0" catenateNumbers="0" catenateAll="0"
splitOnCaseChange="1"/><filter class="solr.LowerCaseFilterFactory"/><filter class="solr.KeywordMarkerFilterFactory"
protected="protwords.txt"/><filter class="solr.PorterStemFilterFactory"/></analyzer></fieldType>



________________________________
 From: David Parks <davidparks21@yahoo.com>
To: "solr-user@lucene.apache.org" <solr-user@lucene.apache.org> 
Sent: Wednesday, March 6, 2013 1:58 PM
Subject: Re: After upgrade to solr4, search doesn't work
 
All but the unique ID field use the out-of-the-box default text_en_splitting field type, this
copied over from v3 to v4 without change as far as I know.

I've done the import from scratch (deleted the solr data directory and re-imported and committed).

<fieldType name="text_en_splitting" class="solr.TextField" positionIncrementGap="100" autoGeneratePhraseQueries="true"><analyzer
type="index"><tokenizer class="solr.WhitespaceTokenizerFactory"/><!-- in this
example, we will only use synonyms at query time <filter class="solr.SynonymFilterFactory"
synonyms="index_synonyms.txt" ignoreCase="true" expand="false"/> --><!-- Case insensitive
stop word removal. add enablePositionIncrements=true in both the index and query analyzers
to leave a 'gap' for more accurate phrase queries. --><filter class="solr.StopFilterFactory"
ignoreCase="true" words="lang/stopwords_en.txt" enablePositionIncrements="true" /><filter
class="solr.WordDelimiterFilterFactory" generateWordParts="1" generateNumberParts="1" catenateWords="1"
catenateNumbers="1" catenateAll="0" splitOnCaseChange="1"/><filter class="solr.LowerCaseFilterFactory"/><filter
class="solr.KeywordMarkerFilterFactory" protected="protwords.txt"/><filter
class="solr.PorterStemFilterFactory"/></analyzer>





________________________________
From: mani arasu <reachmaniarasu@gmail.com>
To: solr-user@lucene.apache.org 
Sent: Wednesday, March 6, 2013 1:37 PM
Subject: Re: After upgrade to solr4, search doesn't work

You should probably be looking at which Analyzer you used in solr version
3.x and which one you are using in solr version 4.x.
If there is any change in that you may have to do either of the following:

   - Do a full-import so that documents are created according to your new
   schema
   - Do a search on the previously created documents, considering the way
   your documents are Analysed and Indexed as per solr version 3.x


On Wed, Mar 6, 2013 at 11:56 AM, David Parks <davidparks21@yahoo.com> wrote:

> I just upgraded from solr3 to solr4, and I wiped the previous work and
> reloaded 500,000 documents.
>
> I see in solr that I loaded the documents, and from the console, if I do a
> query "*:*" I see documents returned.
>
> I copied a single word from the text of the query results I got from "*:*"
> but any query I do with a term returns 0 results, even though it's clear
> from the "*:*" query that solr has that document.
>
> Any ideas on where to start looking here?
>
> David
>
>
>
Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message