lucene-solr-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Rafał Kuć <r....@solr.pl>
Subject Re: Error: _version_field must exist in schema
Date Wed, 17 Oct 2012 22:25:08 GMT
Hello!

You can some find information about requirements of SolrCloud at
http://wiki.apache.org/solr/SolrCloud . I don't know if _version_ is
mentioned elsewhere.

As for Websolr - I'm afraid I can't say anything about the cause of
those errors without seeing the exception. 


-- 
Regards,
 Rafał Kuć
 Sematext :: http://sematext.com/ :: Solr - Lucene - Nutch - ElasticSearch

> On Thu, Oct 18, 2012 at 12:09 AM, Rafał Kuć <r.kuc@solr.pl> wrote:
>> Hello!
>>
>> The _version_ field is needed by some of Solr 4.0 functionality like
>> transaction log or partial documents update. If you want to use them,
>> just update your schema.xml and put the _version_ field definition
>> there.
>>
>> However if you don't want those, you can remove the transaction log
>> configuration in your solrconfig.xml. However please remember that
>> when using SolrCloud you'll need that field.
>>

> Thanks. Where is that bit documented? I don't see it on the Solr wiki:
> http://wiki.apache.org/solr/SchemaXml

> I do have a Solr 4 Beta index running on Websolr that does not have
> such a field. It works, but throws many "Service Unavailable" and
> "Communication Error" errors. Might the lack of the _version_ field be
> the reason?

> Thanks.


Mime
View raw message