lucene-solr-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Jack Krupansky" <j...@basetechnology.com>
Subject Re: Delete all documents in the index
Date Wed, 05 Sep 2012 16:56:55 GMT
Check to make sure that you are not stumbling into SOLR-3432: "deleteByQuery 
silently ignored if updateLog is enabled, but {{_version_}} field does not 
exist in schema".

See:
https://issues.apache.org/jira/browse/SOLR-3432

This could happen if you kept the new 4.0 solrconfig.xml, but copied in your 
pre-4.0 schema.xml.

-- Jack Krupansky

-----Original Message----- 
From: Rohit Harchandani
Sent: Wednesday, September 05, 2012 12:48 PM
To: solr-user@lucene.apache.org
Subject: Delete all documents in the index

Hi,
I am having difficulty deleting documents from the index using curl. The
urls i tried were:
curl "http://localhost:9020/solr/core1/update/?stream.body=
<delete><query>*:*</query></delete>&commit=true"
curl "http://localhost:9020/solr/core1/update/?commit=true" -H
"Content-Type: text/xml" --data-binary '<delete><query>id:[* TO
*]</query></delete>'
curl "http://localhost:9020/solr/core1/update/?commit=true" -H
"Content-Type: text/xml" --data-binary '<delete><query>*:*</query></delete>'
I also tried:
curl "
http://localhost:9020/solr/core1/update/?stream.body=%3Cdelete%3E%3Cquery%3E*:*%3C/query%3E%3C/delete%3E&commit=true
"
as suggested on some forums. I get a response with status=0 in all cases,
but none of the above seem to work.
When I run
curl "http://localhost:9020/solr/core1/select?q=*:*&rows=0&wt=xml"
I still get a value for "numFound".

I am currently using solr 4.0 beta version.

Thanks for your help in advance.
Regards,
Rohit 


Mime
View raw message