lucene-solr-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "tech.vronk" <t...@vronk.net>
Subject Re: configure saxon in 4.x
Date Sat, 29 Sep 2012 11:53:23 GMT

there are certainly multiple ways,
now I found at least one:

in the 4.x package the configuration for the jetty-start.jar
expects the extension libraries in
lib/ext/*

(in 3.6 everything under lib/** was considered)

hope this helps save hours of desperation
to other lost souls (should there be any)
unable to get their configuration right

best,
matej


Am 28.09.2012 17:38, schrieb tech.vronk:
> hi,
>
> i am unable to configure saxon as the xslt-transformer of choice
> in solr 4.x (ALPHA and BETA)
>
> On startup, I keep getting the error:
> null:javax.xml.transform.TransformerFactoryConfigurationError: Pr
> ovider net.sf.saxon.TransformerFactoryImpl not found
> even though the log before says, it is adding the .jars to the 
> class-loader.
>
> I start solr (in the example dir) with:
> java -jar start.jar 
> -Djavax.xml.transform.TransformerFactory=net.sf.saxon.TransformerFactoryImpl
>
> I have set the saxon-jars in the CLASSPATH.
>
> I also tried to put various versions of the saxon-jars into
> ./example/lib or
> ./example/solr/lib
>
> and to edit ./example/solr/collection1/solrconfig.xml
>
>   <lib dir="../../lib" regex="saxon.*\.jar"  />
> and:
>   <lib dir="../lib" regex="saxon.*\.jar"  />
>
>
> What am I doing wrong?
>
>
> Any hint appreciated
>
> best,
> Matej
>
>


Mime
View raw message