lucene-solr-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Bruno Mannina <bmann...@free.fr>
Subject Re: How to Increase the number of connexion on Solr/Tomcat6?
Date Fri, 20 Jul 2012 22:00:24 GMT
Michael,

I'm admin of my server, I have only 2 accounts.

If I use
sudo cd /var/log/tomcat6
I enter the pwd and I get the message:
sudo: cd: command not found

my account is admin.

I don't understand what happens but If I do:
sudo lsof -p pid_of_tomcat |grep log

I see several logs file :
catalinat.out   <-- twice
catalina.2012-07-20.log
localhost.2012-07-20.log

in the /var/log/tomcat6

I can see the content of all .log file but not catalina.out



Le 20/07/2012 23:34, Michael Della Bitta a écrit :
> Bruno,
>
> That sounds like either you need sudo permissions on your machine, or
> you need help from someone who has them. Having a look at the logs in
> there should be fairly revealing.
>
> Failing that, you could always go back to Jetty. :)
>
> Michael Della Bitta
>
> ------------------------------------------------
> Appinions, Inc. -- Where Influence Isn’t a Game.
> http://www.appinions.com
>
>
> On Fri, Jul 20, 2012 at 5:32 PM, Bruno Mannina <bmannina@free.fr> wrote:
>> If I try to do a :
>>
>> cd /var/log/tomcat6
>>
>> I get a permission denied ??!!
>>
>> tomcat6/ directory exists and it has drwxr-x--- 2 tomcat6 adm
>>
>>
>> Le 20/07/2012 23:16, Michael Della Bitta a écrit :
>>
>>> Sorry, if you're running the Ubuntu-provided Tomcat, your log should
>>> be in /var/log/tomcat6/catalina.out.
>>>
>>> Michael Della Bitta
>>>
>>> ------------------------------------------------
>>> Appinions, Inc. -- Where Influence Isn’t a Game.
>>> http://www.appinions.com
>>>
>>>
>>> On Fri, Jul 20, 2012 at 5:09 PM, Bruno Mannina <bmannina@free.fr> wrote:
>>>> Very Strange $CATALINA_HOME is empty ?!!!
>>>>
>>>> Help is welcome !
>>>>
>>>> Another thing, in the /usr/share/tomcat6/catalina.sh I added twice time
>>>> JAVA_OPTS="$JAVA_OPTS ......... -Xms1024m -Xmx2048m -XX:MaxPermSize=512m"
>>>>
>>>>
>>>>
>>>> Le 20/07/2012 23:02, Michael Della Bitta a écrit :
>>>>
>>>>> Hmm, are you seeing any errors in $CATALINA_HOME/logs/catalina.out
>>>>> that suggest that you're running out of permgen space, or anything
>>>>> else?
>>>>>
>>>>> Michael Della Bitta
>>>>>
>>>>> ------------------------------------------------
>>>>> Appinions, Inc. -- Where Influence Isn’t a Game.
>>>>> http://www.appinions.com
>>>>>
>>>>>
>>>>> On Fri, Jul 20, 2012 at 4:55 PM, Bruno Mannina <bmannina@free.fr>
wrote:
>>>>>> hum... by using
>>>>>> |export JAVA_OPTS=||"-Xms1024m -Xmx2048m -XX:MaxPermSize=512m"|
>>>>>>
>>>>>> it seems to be very quick, but I need to add delay between each
>>>>>> requests
>>>>>> because I loose answer with http answer 200 OK :'(
>>>>>>
>>>>>> I must do another and another tests but It's a begin !
>>>>>>
>>>>>> Le 20/07/2012 22:40, Bruno Mannina a écrit :
>>>>>>
>>>>>>> Hi Michael,
>>>>>>>
>>>>>>> I set Xms1024m Xmx2048
>>>>>>>
>>>>>>> I will take a look to your link, thanks !!!
>>>>>>>
>>>>>>> Actually, all my tests works slowly....even with 150 requests
:'(
>>>>>>>
>>>>>>>
>>>>>>> Le 20/07/2012 18:17, Michael Della Bitta a écrit :
>>>>>>>> Hi Bruno,
>>>>>>>>
>>>>>>>> It seems the version of Tomcat I was running was customized
by
>>>>>>>> Canonical to have that parameter. You might try to add it
in... I
>>>>>>>> have
>>>>>>>> no idea what the default is.
>>>>>>>>
>>>>>>>> Do you have any idea how much RAM you're allocating to the
Tomcat
>>>>>>>> process? It could be that something is off there.
>>>>>>>>
>>>>>>>>
>>>>>>>> http://wiki.razuna.com/display/ecp/Adjusting+Memory+Settings+for+Tomcat
>>>>>>>>
>>>>>>>> Michael Della Bitta
>>>>>>>>
>>>>>>>> ------------------------------------------------
>>>>>>>> Appinions, Inc. -- Where Influence Isn’t a Game.
>>>>>>>> http://www.appinions.com
>>>>>>>>
>>>>>>>>
>>>>>>>> On Fri, Jul 20, 2012 at 7:57 AM, Bruno Mannina <bmannina@free.fr>
>>>>>>>> wrote:
>>>>>>>>> More details:
>>>>>>>>> First (around) 50 requests are very quick and after connection
down
>>>>>>>>> (very
>>>>>>>>> slow) and freeze sometime.
>>>>>>>>>
>>>>>>>>> I'm trying to install a tool to see what happens.
>>>>>>>>>
>>>>>>>>>
>>>>>>>>>
>>>>>>>>> Le 20/07/2012 12:09, Bruno Mannina a écrit :
>>>>>>>>>
>>>>>>>>>> Dear Michael,
>>>>>>>>>>
>>>>>>>>>> My system is:
>>>>>>>>>> Ubuntu 12.04
>>>>>>>>>> 8Go Ram
>>>>>>>>>> 4 cores
>>>>>>>>>>
>>>>>>>>>> Concerning connector on server.xml, I don't modified
something, so
>>>>>>>>>> all
>>>>>>>>>> values are default.
>>>>>>>>>> I have only one connector and no maxThreads are define
inside.
>>>>>>>>>>
>>>>>>>>>> <Connector port="8983" protocol="HTTP/1.1"
>>>>>>>>>>                         connectionTimeout="20000"
>>>>>>>>>>                         URIEncoding="UTF-8"
>>>>>>>>>>                         redirectPort="8443" />
>>>>>>>>>>
>>>>>>>>>>
>>>>>>>>>> Must I add a line with maxThreads=....?
>>>>>>>>>>
>>>>>>>>>>
>>>>>>>>>>
>>>>>>>>>> Le 20/07/2012 03:31, Michael Della Bitta a écrit
:
>>>>>>>>>>> Hi Bruno,
>>>>>>>>>>>
>>>>>>>>>>> It's usually the maxThreads attribute in the
<Connector> tag in
>>>>>>>>>>> $CATALINA_HOME/conf/server.xml. But I kind of
doubt you're running
>>>>>>>>>>> out
>>>>>>>>>>> of threads... maybe you could post some more
details about the
>>>>>>>>>>> system
>>>>>>>>>>> you're running Solr on.
>>>>>>>>>>>
>>>>>>>>>>> Michael Della Bitta
>>>>>>>>>>>
>>>>>>>>>>> ------------------------------------------------
>>>>>>>>>>> Appinions, Inc. -- Where Influence Isn’t a
Game.
>>>>>>>>>>> http://www.appinions.com
>>>>>>>>>>>
>>>>>>>>>>>
>>>>>>>>>>> On Thu, Jul 19, 2012 at 6:47 PM, Bruno Mannina
<bmannina@free.fr>
>>>>>>>>>>> wrote:
>>>>>>>>>>>> Dear Solr User,
>>>>>>>>>>>>
>>>>>>>>>>>> I don't know if it's here that my question
must be posted but I'm
>>>>>>>>>>>> sure
>>>>>>>>>>>> some
>>>>>>>>>>>> users have already had my problem.
>>>>>>>>>>>>
>>>>>>>>>>>> Actually, I do 1556 requests with 4 Http
components with my
>>>>>>>>>>>> program.
>>>>>>>>>>>> If
>>>>>>>>>>>> I do
>>>>>>>>>>>> these requests without delay (500ms)
>>>>>>>>>>>> before sending each requests I have around
10% of requests with
>>>>>>>>>>>> empty
>>>>>>>>>>>> answer. If I add delay before each requests
I have no empty
>>>>>>>>>>>> answer.
>>>>>>>>>>>>
>>>>>>>>>>>> Empty answer has HTTP 200 OK, Header OK but
Body = ''
>>>>>>>>>>>>
>>>>>>>>>>>> Where can I increase the limit of Tomcat/Solr
requests at the
>>>>>>>>>>>> same
>>>>>>>>>>>> time
>>>>>>>>>>>> or
>>>>>>>>>>>> how can I solve my problem.
>>>>>>>>>>>>
>>>>>>>>>>>> Thanks a lot for your Help,
>>>>>>>>>>>> Bruno
>>>>>>>>>>>
>


Mime
View raw message