lucene-solr-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Michael Della Bitta <michael.della.bi...@appinions.com>
Subject Re: Replication Issue
Date Fri, 29 Jun 2012 16:54:22 GMT
Nevermind, I realized that my master index was not tickling the index
version number when a commit or optimize happened. I gave in and nuke
and paved it, and now it seems fine.

Is there any known reason why this would happen, so I can avoid this
in the future?

Thanks,


Michael Della Bitta

------------------------------------------------
Appinions, Inc. -- Where Influence Isn’t a Game.
http://www.appinions.com


On Fri, Jun 29, 2012 at 10:42 AM, Michael Della Bitta
<michael.della.bitta@appinions.com> wrote:
> Hi, I'm having trouble with replication on a brand new rollout of 3.6.
>
> Basically I've traced it to the slave always thinking the index it
> creates when it warms up is newer than what's on the master, no matter
> what I do... deleting the slave's index, committing or optimizing on
> the master, etc. I can see the replication request come in on the
> master, but nothing happens, presumably because of the Index Version
> discrepancy.
>
> The clocks of the two machines are within 3 seconds of one another,
> but I don't know if that's significant.
>
> Actually, I'm having trouble figuring out how Index Version is
> calculated at all, and before I dive into the source, I thought I'd
> ask here. My slave is saying Index Version 1340979968338, Generation
> 1, and my master says Index Version 1340052708476, Generation 83549.
>
> Anybody have any ideas?
>
> Thanks,
>
> Michael Della Bitta
>
> ------------------------------------------------
> Appinions, Inc. -- Where Influence Isn’t a Game.
> http://www.appinions.com

Mime
View raw message