lucene-solr-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Giovanni Gherdovich <g.gherdov...@gmail.com>
Subject querying thru solritas gives me zero results
Date Sat, 30 Jun 2012 11:36:13 GMT
Hi all,

this morning I was very proud of myself since I managed
to set up solritas ( http://wiki.apache.org/solr/VelocityResponseWriter )
for the solr instance on my server (ubuntu natty).

This joy lasted only half a minute, since the only query
that gets more than zero results with solritas is the catchall "*:*"

for example:
http://my.server.com:8080/solr/select/?q=foobar has thousands of results,
​http://my.server.com:8080/solr/itas?q=foobar has none

Here the standard and "velocity" request handlers from my solrconfig.xml;

-- -- >8  -- -- >8  -- -- >8  -- -- >8  -- -- >8  -- -- >8
  <requestHandler name="standard" class="solr.SearchHandler" default="true">
     <lst name="defaults">
       <str name="echoParams">explicit</str>
     </lst>
  </requestHandler>
-- -- >8  -- -- >8  -- -- >8  -- -- >8  -- -- >8  -- -- >8

-- -- >8  -- -- >8  -- -- >8  -- -- >8  -- -- >8  -- -- >8
  <queryResponseWriter name="velocity"
class="org.apache.solr.request.VelocityResponseWriter"/>
  <requestHandler name="/itas" class="solr.SearchHandler">
    <lst name="defaults">
      <str name="wt">velocity</str>
      <str name="v.template">browse</str>
      <str name="title">Solr cookbook example</str>
      <str name="defType">dismax</str>
      <str name="q.alt">*:*</str>
      <str name="rows">10</str>
      <str name="fl">*,score</str>
      <str name="qf">name</str>
    </lst>
  </requestHandler>
-- -- >8  -- -- >8  -- -- >8  -- -- >8  -- -- >8  -- -- >8

any hint on how I can debug that?

cheers,
Giovanni

Mime
View raw message