lucene-solr-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Chris Hostetter <hossman_luc...@fucit.org>
Subject Re: Problem with facet.fields
Date Wed, 04 Jan 2012 20:23:14 GMT

: If I put : q=*:*&facet=true&facet.field=lom.classification.ddc.id
: => I have results for facet fields
: If I put : q=*:*&facet=true&facet.field=lom.educational.context
: => I have results for facet fields
: 
: But if I put : q=*:*&facet=true&facet.field=lom.classification.ddc.id
: &facet.field=lom.educational.context
: 
: I have only facet results for the first field. I tried to invert them and
: got also only results for the first field. It is like the the second field
: was ignored.

How are you doing these queries?  Are you using some sort of client 
library via some langauge, or are you pasting those URL snippets into a 
browser?  what does the "responseHeader" section of the results look like 
if you add echoParams=all to the URL?  what servlet container are you using?

My suspicion is that you are using some client library that doesn't 
understand multivalued URL params and is just putting them into a map, the 
responseHeader w/echoParams turned on will tell you exactly what Solr is 
getting.

I just tried this using the example schema in Solr 3.5 and it worked 
fine...

http://localhost:8983/solr/select?echoParams=all&q=*:*&facet=true&facet.field=lom.classification.ddc.id_s&facet.field=lom.educational.context_s

: Furthermore I tried :
: q=*:*&facet=true&facet.field=lom.classification.ddc.id&facet.field=foo
: => it works although the 'foo' field doesn't exist
: q=*:*&facet=true&facet.field=lom.classification.ddc.id&facet.field=foo
: => gives me an error telling me the 'foo' field doesn't exist.

i don't understand these last examples at all ... both of those lines are 
identical


-Hoss

Mime
View raw message