lucene-solr-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Erick Erickson <erickerick...@gmail.com>
Subject Re: quoted query issue
Date Mon, 05 Dec 2011 14:09:06 GMT
1> Try adding &debugQuery=on and see if the query parses the way
you expect.

2> Look at your admin/analysis page to see if your fields are getting
     parsed the way you think.

3> Look in your admin/schema page to see if the actual terms are
     what you expect...

Yeah, it's kind of daunting when it just doesn't work, but it often
boils down to your schema not doing quite what you expect.

Best
Erick

On Sun, Dec 4, 2011 at 3:41 PM, C Hagenmaier <cyclecarl-me@yahoo.com> wrote:
> My query for the terms road and show
>
> <str name="q">body:(road show)</str>
>
> returns 4 documents.  The highlighting shows several instances where road
> immediately precedes show.  However, a query for the phrase "road show"
>
> <str name="q">body:("road show")</str>
>
> returns no documents.  I have similar results with "floor show" and "road
> house."  I have verified that the indexed text field contains the phrases I'm
> searching.
>
>
> Here's the XML response
>
> <response><lst name="responseHeader"><int name="status">0</int><int
> name="QTime">1</int><lst name="params"><str name="hl">on</str><str
> name="version">2.2</str><str name="fl">identifier,title,year,volume</str><str
> name="api">c7aab49e267</str><str name="qt"/><str name="fq"/><str
> name="explainOther"/><str name="hl.fl">body</str><str name="wt"/><str
> name="rows">10</str><str name="start">0</str><str name="q">body:("road
> show")</str></lst></lst><result name="response" numFound="0" start="0"/><lst
> name="highlighting"/></response>
>
> What do I do now?
>
> --
> Carl
>

Mime
View raw message