lucene-solr-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Donald Organ <dor...@donaldorgan.com>
Subject Re: Unable to get multicore working
Date Tue, 16 Aug 2011 21:30:02 GMT
When you go to /solr  what do you see?

On Tue, Aug 16, 2011 at 5:23 PM, David Sauve <dnsauve@gmail.com> wrote:

> I updated my `solr.xml` as follow:
>
> <?xml version="1.0" encoding="UTF-8" ?>
> <solr persistent="false">
> <cores adminPath="/admin/cores" defaultCoreName="live">
> <core name="preview" instanceDir="/home/webteam/config/search/preview"
> dataDir="/home/webteam/preview/data" />
> <core name="staging" instanceDir="/home/webteam/config/search/staging"
> dataDir="/home/webteam/staging/data" />
> <core name="live" instanceDir="/home/webteam/config/search/live"
> dataDir="/home/webteam/live/data" />
> </cores>
> </solr>
>
>
> and I'm still seeing the same 404 when I true to view /solr/admin/ or
> /solr/live/admin/
>
> That said, the logs are showing a different error now. Excellent! The site
> schemas are loading!
>
> Looks like the site schemas have an issue:
>
> "SEVERE: org.apache.solr.common.SolrException: Unknown fieldtype 'long'
> specified on field area_id"
>
> Errr. Why would `long` be an invalid type?
>
>
> On Tuesday, 16 August, 2011 at 2:06 PM, Jaeger, Jay - DOT wrote:
>
> > Whoops: That was Solr 4.0 (which pre-dates 3.1).
> >
> > I doubt very much that the release matters, though: I expect the behavior
> would be the same.
> >
> > -----Original Message-----
> > From: Jaeger, Jay - DOT [mailto:Jay.Jaeger@dot.wi.gov]
> > Sent: Tuesday, August 16, 2011 4:04 PM
> > To: solr-user@lucene.apache.org (mailto:solr-user@lucene.apache.org)
> > Subject: RE: Unable to get multicore working
> >
> > I tried on my own test environment -- pulling out the default core
> parameter out, under Solr 3.1
> >
> > I got exactly your symptom: an error 404.
> >
> >  HTTP ERROR 404
> >  Problem accessing /solr/admin/index.jsp. Reason:
> >
> >  missing core name in path
> >
> > The log showed:
> >
> > 2011-08-16 16:00:12.469:WARN::/solr/admin/
> > java.lang.IllegalStateException: STREAM
> >  at org.mortbay.jetty.Response.getWriter(Response.java:616)
> >  at
> org.apache.jasper.runtime.JspWriterImpl.initOut(JspWriterImpl.java:187)
> >  at
> org.apache.jasper.runtime.JspWriterImpl.flushBuffer(JspWriterImpl.java:180)
> >  at
> org.apache.jasper.runtime.PageContextImpl.release(PageContextImpl.java:237)
> >  at
> org.apache.jasper.runtime.JspFactoryImpl.internalReleasePageContext(JspFactoryImpl.java:173)
> >  at
> org.apache.jasper.runtime.JspFactoryImpl.releasePageContext(JspFactoryImpl.java:124)
> >
> > (etc.)
> >
> > Adding the defaultCoreName fixed it.
> >
> > I expect this is indeed your problem.
> >
> > -----Original Message-----
> > From: David Sauve [mailto:dnsauve@gmail.com]
> > Sent: Tuesday, August 16, 2011 3:50 PM
> > To: solr-user@lucene.apache.org (mailto:solr-user@lucene.apache.org)
> > Subject: Re: Unable to get multicore working
> >
> > Nope. Only thing in the log:
> >
> > 1 [main] INFO org.mortbay.log - Logging to
> org.slf4j.impl.SimpleLogger(org.mortbay.log) via org.mortbay.log.Slf4jLog
> > 173 [main] INFO org.mortbay.log - Redirecting stderr/stdout to
> /var/log/jetty/2011_08_16.stderrout.log
> >
> >
> >
> >
> > On Tuesday, 16 August, 2011 at 1:45 PM, Alexei Martchenko wrote:
> >
> > > Is your solr.xml in usr/share/jetty/solr/solr.xml?
> > >
> > > lets try this xml instead
> > >
> > > <?xml version="1.0" encoding="UTF-8" ?>
> > > <solr persistent="true">
> > > <cores adminPath="/admin/cores">
> > > <core name="core01" instanceDir="core01" />
> > > <core name="core02" instanceDir="core02" />
> > > <core name="core03" instanceDir="core03" />
> > > </cores>
> > > </solr>
> > >
> > > Can you see the logs? You should see something like this
> > >
> > > 16/08/2011 17:30:55 org.apache.solr.core.SolrResourceLoader <init>
> > > *INFO: Solr home set to 'solr/'*
> > > 16/08/2011 17:30:55 org.apache.solr.servlet.SolrDispatchFilter init
> > > INFO: SolrDispatchFilter.init()
> > > 16/08/2011 17:30:55 org.apache.solr.core.SolrResourceLoader
> locateSolrHome
> > > INFO: JNDI not configured for solr (NoInitialContextEx)
> > > 16/08/2011 17:30:55 org.apache.solr.core.SolrResourceLoader
> locateSolrHome
> > > *INFO: solr home defaulted to 'solr/' (could not find system property
> or
> > > JNDI)*
> > > 16/08/2011 17:30:55 org.apache.solr.core.CoreContainer$Initializer
> > > initialize
> > > *INFO: looking for solr.xml: usr/share/jetty/solr/solr.xml*
> > > 16/08/2011 17:30:55 org.apache.solr.core.SolrResourceLoader
> locateSolrHome
> > > INFO: JNDI not configured for solr (NoInitialContextEx)
> > > 16/08/2011 17:30:55 org.apache.solr.core.SolrResourceLoader
> locateSolrHome
> > > *INFO: solr home defaulted to 'solr/' (could not find system property
> or
> > > JNDI)*
> > > 16/08/2011 17:30:55 org.apache.solr.core.CoreContainer <init>
> > > *INFO: New CoreContainer: solrHome=solr/ instance=21357269*
> > > 16/08/2011 17:30:55 org.apache.solr.core.SolrResourceLoader <init>
> > > *INFO: Solr home set to 'solr/'*
> > > 16/08/2011 17:30:55 org.apache.solr.core.SolrResourceLoader <init>
> > > *INFO: Solr home set to 'solr\core01\'*
> > >
> > > 2011/8/16 David Sauve <dnsauve@gmail.com (mailto:dnsauve@gmail.com)>
> > >
> > > > Just the one `solr.xml`. The one I added (well, symlinked form my
> config
> > > > folder -- I like to keep my configurations files organized so they
> can be
> > > > managed by git)
> > > >
> > > > `start.jar` is in `usr/share/jetty/start.jar`.
> > > >
> > > >
> > > > On Tuesday, 16 August, 2011 at 1:33 PM, Alexei Martchenko wrote:
> > > >
> > > > > AFAIK you're still seeing singlecore version....
> > > > >
> > > > > where is your start.jar?
> > > > >
> > > > > search for solr.xml, see how many u've got plz.
> > > > >
> > > > > 2011/8/16 David Sauve <dnsauve@gmail.com (mailto:dnsauve@gmail.com
> )>
> > > > >
> > > > > >  I've installed using aptitude so I don't have an example folder
> (that
> > > > I
> > > > > > can find).
> > > > > >
> > > > > > /solr/ does work (but lists no cores)
> > > > > > /solr/live/admin/ does not -- 404
> > > > > >
> > > > > >
> > > > > > On Tuesday, 16 August, 2011 at 1:13 PM, Alexei Martchenko wrote:
> > > > > >
> > > > > > > Lets try something simplier.
> > > > > > > My start.jar is on \apache-solr-3.3.0\example\
> > > > > > > Here's my local config placed in
> \apache-solr-3.3.0\example\solr\
> > > > > > >
> > > > > > > <?xml version="1.0" encoding="UTF-8" ?>
> > > > > > > <solr persistent="true">
> > > > > > > <cores adminPath="/admin/cores">
> > > > > > > <core name="softwares01" instanceDir="softwares01" />
> > > > > > > </cores>
> > > > > > > </solr>
> > > > > > >
> > > > > > > Create \apache-solr-3.3.0\example\solr\softwares01\conf\
> > > > > > > and \apache-solr-3.3.0\example\solr\softwares01\data\
> > > > > > >
> > > > > > > http://localhost:8983/solr/ should work and so is
> > > > > > > http://localhost:8983/solr/softwares01/admin/
> > > > > > >
> > > > > > >
> > > > > > >
> > > > > > > 2011/8/16 David Sauve <dnsauve@gmail.com (mailto:
> dnsauve@gmail.com)>
> > > > > > >
> > > > > > > > I've been trying (unsuccessfully) to get multicore
working
> for
> > > > about a
> > > > > > day
> > > > > > > > and a half now I'm nearly at wits end and unsure what
to do
> > > > anymore.
> > > > > > **Any**
> > > > > > > > help would be appreciated.
> > > > > > > >
> > > > > > > > I've installed Solr using the solr-jetty packages
on Ubuntu
> 10.04.
> > > > The
> > > > > > > > default Solr install seems to work fine.
> > > > > > > >
> > > > > > > > Now, I want to add three cores: live, staging, preview
to be
> used
> > > > for
> > > > > > the
> > > > > > > > various states of the site.
> > > > > > > >
> > > > > > > > I've created a `solr.xml` file as follows and symlinked
it in
> to
> > > > > > > > /usr/share/solr:
> > > > > > > >
> > > > > > > > <?xml version="1.0" encoding="UTF-8" ?>
> > > > > > > > <solr persistent="false">
> > > > > > > > <cores adminPath="/admin/cores">
> > > > > > > > <core name="preview"
> > > > instanceDir="/home/webteam/config/search/preview"
> > > > > > > > dataDir="/home/webteam/preview/data" />
> > > > > > > > <core name="staging"
> > > > instanceDir="/home/webteam/config/search/staging"
> > > > > > > > dataDir="/home/webteam/staging/data" />
> > > > > > > > <core name="live"
> instanceDir="/home/webteam/config/search/live"
> > > > > > > > dataDir="/home/webteam/live/data" />
> > > > > > > > </cores>
> > > > > > > > </solr>
> > > > > > > >
> > > > > > > > Now, when I try to view any cores, I get a 404 - Not
found.
> In
> > > > fact, I
> > > > > > > > can't even view /solr/admin/ anymore after installing
that
> > > > `solr.xml`
> > > > > > file.
> > > > > > > >
> > > > > > > > Also, /solr/admin/cores returns an XML file, but it
looks to
> me
> > > > like
> > > > > > > > there's no cores listed. The output:
> > > > > > > >
> > > > > > > > <response>
> > > > > > > > <lst name="responseHeader">
> > > > > > > > <int name="status">0</int>
> > > > > > > > <int name="QTime">0</int>
> > > > > > > >
> > > > > > > > </lst>
> > > > > > > >
> > > > > > > >
> > > > > > > > <lst name="status"/>
> > > > > > > >
> > > > > > > > </response>
> > > > > > > >
> > > > > > > >
> > > > > > > > Finally, looking through the logs produced by Jetty
doesn't
> seem to
> > > > > > reveal
> > > > > > > > any clues about what is wrong. There doesn't seem
to be any
> errors
> > > > in
> > > > > > there,
> > > > > > > > except the 404s.
> > > > > > > >
> > > > > > > > Long story short. I'm stuck. Any suggestions on where
to go
> with
> > > > this?
> > > > > > > >
> > > > > > > > David
> > > > > > >
> > > > > > >
> > > > > > > --
> > > > > > >
> > > > > > > *Alexei Martchenko* | *CEO* | Superdownloads
> > > > > > > alexei@superdownloads.com.br (mailto:
> alexei@superdownloads.com.br) |
> > > > > > alexei@martchenko.com.br (mailto:alexei@martchenko.com.br) |
> (11)
> > > > > > > 5083.1018/5080.3535/5080.3533
> > > > >
> > > > >
> > > > > --
> > > > >
> > > > > *Alexei Martchenko* | *CEO* | Superdownloads
> > > > > alexei@superdownloads.com.br (mailto:alexei@superdownloads.com.br)
> |
> > > > alexei@martchenko.com.br (mailto:alexei@martchenko.com.br) | (11)
> > > > > 5083.1018/5080.3535/5080.3533
> > >
> > >
> > > --
> > >
> > > *Alexei Martchenko* | *CEO* | Superdownloads
> > > alexei@superdownloads.com.br (mailto:alexei@superdownloads.com.br) |
> alexei@martchenko.com.br (mailto:alexei@martchenko.com.br) | (11)
> > > 5083.1018/5080.3535/5080.3533
>
>

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message