lucene-solr-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From alexander sulz <a.s...@digiconcept.net>
Subject Re: Solr 3.3 crashes after ~18 hours?
Date Fri, 19 Aug 2011 13:48:30 GMT
Am 10.08.2011 17:11, schrieb Yonik Seeley:
> On Wed, Aug 10, 2011 at 11:00 AM, alexander sulz<a.sulz@digiconcept.net>  wrote:
>> Okay, with this command it hangs.
> It doesn't look like a hang from this thread dump.  It doesn't look
> like any solr requests are executing at the time the dump was taken.
>
> Did you do this from the command line?
> curl "http://localhost:8983/solr/update?commit=true"
>
> Are you saying that the curl command just hung and never returned?
>
> -Yonik
> http://www.lucidimagination.com
>
>> Also: I managed to get a Thread Dump (attached).
>>
>> regards
>>
>> Am 05.08.2011 15:08, schrieb Yonik Seeley:
>>> On Fri, Aug 5, 2011 at 7:33 AM, alexander sulz<a.sulz@digiconcept.net>
>>>   wrote:
>>>> Usually you get a XML-Response when doing commits or optimize, in this
>>>> case
>>>> I get nothing
>>>> in return, but the site ( http://[...]/solr/update?optimize=true )
>>>> DOESN'T
>>>> load forever or anything.
>>>> It doesn't hang! I just get a blank page / empty response.
>>> Sounds like you are doing it from a browser?
>>> Can you try it from the command line?  It should give back some sort
>>> of response (or hang waiting for a response).
>>>
>>> curl "http://localhost:8983/solr/update?commit=true"
>>>
>>> -Yonik
>>> http://www.lucidimagination.com
>>>
>>>
>>>> I use the stuff in the example folder, the only changes i made was enable
>>>> logging and changing the port to 8985.
>>>> I'll try getting a thread dump if it happens again!
>>>> So far its looking good with having allocated more memory to it.
>>>>
>>>> Am 04.08.2011 16:08, schrieb Yonik Seeley:
>>>>> On Thu, Aug 4, 2011 at 8:09 AM, alexander sulz<a.sulz@digiconcept.net>
>>>>>   wrote:
>>>>>> Thank you for the many replies!
>>>>>>
>>>>>> Like I said, I couldn't find anything in logs created by solr.
>>>>>> I just had a look at the /var/logs/messages and there wasn't anything
>>>>>> either.
>>>>>>
>>>>>> What I mean by crash is that the process is still there and http
GET
>>>>>> pings
>>>>>> would return 200
>>>>>> but when i try visiting /solr/admin, I'd get a blank page! The server
>>>>>> ignores any incoming updates or commits,
>>>>> "ignores" means what?  The request hangs?  If so, could you get a thread
>>>>> dump?
>>>>>
>>>>> Do queries work (like /solr/select?q=*:*) ?
>>>>>
>>>>>> thous throwing no errors, no 503's.. It's like the server has a
>>>>>> blackout
>>>>>> and
>>>>>> stares blankly into space.
>>>>> Are you using a different servlet container than what is shipped with
>>>>> solr?
>>>>> If you did start with the solr "example" server, what jetty
>>>>> configuration changes have you made?
>>>>>
>>>>> -Yonik
>>>>> http://www.lucidimagination.com
>>
Sigh it happened again, but I have a clue: before the crash I was 
deleting some entries but haven't optimized afterwards, then, when I 
tried indexing something, solr "crashed" again (responsive but just 
blank/empty returns).

I've just tried it again (doing the curl command while solr is its 
"zombie state")
and i get the following reply from curl: "curl: (52) Empty reply from 
server"

Also, I updated my Java so the HotSpot version is now 20.1-b3


Mime
View raw message