lucene-solr-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Jayendra Patil <jayendra.patil....@gmail.com>
Subject Re: Master Slave help
Date Tue, 07 Jun 2011 01:25:58 GMT
Do you mean the replication happens everytime you restart the server ?
If so, you would need to modify the events you want the replication to happen.

Check for the replicateAfter tag and remove the startup option, if you
don't need it.

<requestHandler name="/replication" class="solr.ReplicationHandler" >
    <lst name="master">
        <!--Replicate on 'startup' and 'commit'. 'optimize' is also a
valid value for replicateAfter. -->
        <str name="replicateAfter">startup</str>
        <str name="replicateAfter">commit</str>

        <!--Create a backup after 'optimize'. Other values can be
'commit', 'startup'. It is possible to have multiple entries of this
config string.  Note that this is just for backup, replication does
not require this. -->
        <!-- <str name="backupAfter">optimize</str> -->

        <!--If configuration files need to be replicated give the
names here, separated by comma -->
        <str name="confFiles">schema.xml,stopwords.txt,elevate.xml</str>
       <!--The default value of reservation is 10 secs.See the
documentation below . Normally , you should not need to specify this
-->
        <str name="commitReserveDuration">00:00:10</str>
    </lst>
</requestHandler>

Regards,
Jayendra

On Mon, Jun 6, 2011 at 11:24 AM, Rohit Gupta <rohit@in-rev.com> wrote:
> Hi,
>
> I have configured my master slave server and everything seems to be running
> fine, the replication completed the firsttime it ran. But everytime I go the the
> replication link in the admin panel after restarting the server or server
> startup I notice the replication starting from scratch or at least the stats
> show that.
>
> What could be wrong?
>
> Thanks,
> Rohit

Mime
View raw message