lucene-solr-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Marc Sturlese <marc.sturl...@gmail.com>
Subject Re: problem with the new IndexSearcher when snpainstaller (and commit script) happen
Date Wed, 15 Jun 2011 12:17:02 GMT
Test are done on Solr 1.4
The simplest way to reproduce my problem is having 2 indexes and a Solr box
with just one core. Both index must have been created with the same schema.

1- Remove the index dir of the core and start the server (core is up with an
empty index)
2- check status page of the core (version,numDocs,maxDocs version should be
X and numDocs,maxDocs zero)
3- mv index to index.old
4- mv your folderA (wich contains an index) to index
5- execute curl http://localhost:8080/solr/coreA/update?commit=true -H
"Content-Type: text/xml" 
* Here the log shows me that commit has been executed and new IndexSearcher
has been registered and proper warming has been done.
6- Check the core status page (here all has changed:
version,numDocs,maxDocs)

If now I repeat steps 3,4,5 (in this case using folderB with another index),
when I do step 6, indexVersion has changed but numDocs and maxDocs stay the
same, which I can't understand in any way. (opening the index with my script
shows me that are not).

I've ended up doing this test after noticing the problem before with the
snapinstaller and commit.

--
View this message in context: http://lucene.472066.n3.nabble.com/problem-with-the-new-IndexSearcher-when-snpainstaller-and-commit-script-happen-tp3066902p3067042.html
Sent from the Solr - User mailing list archive at Nabble.com.

Mime
View raw message