lucene-solr-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From roySolr <royrutten1...@gmail.com>
Subject WordDelimiter and stemEnglishPossessive doesn't work
Date Fri, 10 Jun 2011 07:51:06 GMT
Hello,

I have some problem with the wordDelimiter. My data looks like this:

mcdonald's#burgerking#Free record shop#h&m

I want to tokenize this on #. After that it has to split on whitespace. I
use the
wordDelimiter for that(can't use 2 tokenizers)

Now this works but there is one problem, it removes the '. My index looks
like this:

mcdonald
burgerking
free
record
shop
h&m

I don't want this so i use the stemEnglishPossessive. The description from
this part of the filter looks like this:

stemEnglishPossessive="1" causes trailing "'s" to be removed for each
subword.
    "Doug's" => "Doug"
    default is true ("1"); set to 0 to turn off 

My Field looks like this:

<fieldType name="Test_field" class="solr.TextField">
  <analyzer>
    <charFilter class="solr.HTMLStripCharFilterFactory"/>
    <tokenizer class="solr.PatternTokenizerFactory" pattern="#" />
    <filter class="solr.WordDelimiterFilterFactory" 
        		splitOnCaseChange="0" 
        		splitOnNumerics="0"
        		stemEnglishPossessive="0"
        		catenateWords="0"
     />
  </analyzer>
</fieldType>

It looks like the stemEnglishPossessive=0 is not working. How can i fix this
problem? Other filter? Did i forget something?

--
View this message in context: http://lucene.472066.n3.nabble.com/WordDelimiter-and-stemEnglishPossessive-doesn-t-work-tp3047678p3047678.html
Sent from the Solr - User mailing list archive at Nabble.com.

Mime
View raw message