lucene-solr-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Ezequiel Calderara <ezech...@gmail.com>
Subject Re: Problem with Master
Date Fri, 29 Apr 2011 15:00:02 GMT
Just to add more info... this is the result of a Replication / Command=Details

I'm really confused by the masterDetails/indexSize being 52 byts (its
correct), but the indexSize being 303.8 KB

  <?xml version="1.0" encoding="UTF-8" ?>
- <response>
- <lst name="responseHeader">
  <int name="status">0</int>
  <int name="QTime">15</int>
  </lst>
- <lst name="details">
  <str name="indexSize">303.8 KB</str>
  <str name="indexPath">D:\Solr\data\solr\index</str>
  <arr name="commits" />
  <str name="isMaster">false</str>
  <str name="isSlave">true</str>
  <long name="indexVersion">1301331343628</long>
  <long name="generation">3</long>
- <lst name="slave">
- <lst name="masterDetails">
  <str name="indexSize">52 bytes</str>
  <str name="indexPath">D:\Solr\data\solr\index</str>
- <arr name="commits">
- <lst>
  <long name="indexVersion">1304086785516</long>
  <long name="generation">1</long>
- <arr name="filelist">
  <str>segments_1</str>
  </arr>
  </lst>
  </arr>
  <str name="isMaster">true</str>
  <str name="isSlave">false</str>
  <long name="indexVersion">1304086785516</long>
  <long name="generation">1</long>
  </lst>
  <str name="masterUrl">http://192.168.211.185:8787/solr/replication</str>
  <str name="pollInterval">00:00:60</str>
  <str name="nextExecutionAt">Fri Apr 29 12:04:57 ART 2011</str>
  <str name="indexReplicatedAt">Fri Apr 29 12:03:57 ART 2011</str>
- <arr name="indexReplicatedAtList">
  <str>Fri Apr 29 12:03:57 ART 2011</str>
  <str>Fri Apr 29 12:02:57 ART 2011</str>
  <str>Fri Apr 29 12:01:57 ART 2011</str>
  <str>Fri Apr 29 12:00:57 ART 2011</str>
  <str>Fri Apr 29 11:59:57 ART 2011</str>
  <str>Fri Apr 29 11:58:57 ART 2011</str>
  <str>Fri Apr 29 11:57:57 ART 2011</str>
  <str>Fri Apr 29 11:56:57 ART 2011</str>
  <str>Fri Apr 29 11:55:57 ART 2011</str>
  <str>Fri Apr 29 11:54:57 ART 2011</str>
  </arr>
- <arr name="replicationFailedAtList">
  <str>Fri Apr 29 12:03:57 ART 2011</str>
  <str>Fri Apr 29 12:02:57 ART 2011</str>
  <str>Fri Apr 29 12:01:57 ART 2011</str>
  <str>Fri Apr 29 12:00:57 ART 2011</str>
  <str>Fri Apr 29 11:59:57 ART 2011</str>
  <str>Fri Apr 29 11:58:57 ART 2011</str>
  <str>Fri Apr 29 11:57:57 ART 2011</str>
  <str>Fri Apr 29 11:56:57 ART 2011</str>
  <str>Fri Apr 29 11:55:57 ART 2011</str>
  <str>Fri Apr 29 11:54:57 ART 2011</str>
  </arr>
  <str name="timesIndexReplicated">44794</str>
  <str name="confFilesReplicated">[solrconfig_slave.xml]</str>
  <str name="timesConfigReplicated">1</str>
  <str name="confFilesReplicatedAt">1301405968250</str>
  <str name="lastCycleBytesDownloaded">0</str>
  <str name="timesFailed">44792</str>
  <str name="replicationFailedAt">Fri Apr 29 12:03:57 ART 2011</str>
  <str name="previousCycleTimeInSeconds">0</str>
  <str name="isPollingDisabled">false</str>
  <str name="isReplicating">false</str>
  </lst>
  </lst>
  <str name="WARNING">This response format is experimental. It is
likely to change in the future.</str>
  </response>

On Fri, Apr 29, 2011 at 11:52 AM, Ezequiel Calderara <ezechico@gmail.com> wrote:
> Hello, i'm having some issues with replication in my production environment.
>
> I have a master and 4 slaves.
> I had some data indexed and was replicated successfully.
>
> We are close to make the production environment public, so i deleted
> the old data deleting the data folder in the master
> Then i reloaded the master (from the manager of tomcat) hoping that
> the slaves will get updated with the new empty index.
>
> But when i enter to each slave in the replication page, i see that
> they have the old index. Even if i manually tell them to replicate,
> the replication count increases but there is no change in the indexed
> data.
>
> I checked the logs of the master and slaves and i see no error. I do
> see the /replication request reaching to the master.
> I put the SolrCore and ReplicationHandler log's level to "FINEST".
> Still nothing.
>
> I went agains the slave with the command=details
> and i saw a list of ReplicationList and FailedList. And the failed
> list  indicating that the replication is failing. But i don't know why
> and i don't know where to look for the error.
>
> Thanks in advance, this is really urgent.
>
>
> PD: I hope this goes thru the spam filter...
>



-- 
______
Ezequiel.

Http://www.ironicnet.com

Mime
View raw message