lucene-solr-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Ezequiel Calderara <ezech...@gmail.com>
Subject Solrcore.properties
Date Mon, 28 Mar 2011 18:06:17 GMT
Hi all, i'm having problems when deploying solr in the production machines.

I have a master solr, and 3 slaves.
The master replicates the schema and the solrconfig for the slaves (this
file in the master is named like solrconfig_slave.xml).
The solrconfig of the slaves has for example the ${data.dir} and other
values in the solrtcore.properties

I think that solr isn't recognizing that file, because i get this error:

> HTTP Status 500 - Severe errors in solr configuration. Check your log files
> for more detailed information on what may be wrong. If you want solr to
> continue after configuration errors, change:
> <abortOnConfigurationError>false</abortOnConfigurationError> in null
> -------------------------------------------------------------
> org.apache.solr.common.SolrException: No system property or default value
> specified for enable.master at
> org.apache.solr.common.util.DOMUtil.substituteProperty(DOMUtil.java:311)
> ... MORE STACK TRACE INFO...
>
But here is the thing:
org.apache.solr.common.SolrException: No system property or default value
specified for enable.master

I'm attaching the master schema, the master solr config, the solr config of
the slaves and the solrcore.properties.

If anyone has any info on this i would be more than appreciated!...

Thanks


-- 
______
Ezequiel.

Http://www.ironicnet.com

Mime
View raw message