lucene-solr-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Churchill Nanje Mambe <mambena...@afrovisiongroup.com>
Subject Re: SOLR 1.4 and Lucene 3.0.3 index problem
Date Tue, 01 Feb 2011 16:34:02 GMT
So I should use 1.4.1, and that is already built
what if I use solr 4 ?? from the source code do you know of any tutorial I
can use to learn how to build it using netbeans IDE ??
 I already have ant installed
 or you advice I go with the 1.4.1 ??

Mambe Churchill Nanje
237 33011349,
AfroVisioN Founder, President,CEO
http://www.afrovisiongroup.com | http://mambenanje.blogspot.com
skypeID: mambenanje
www.twitter.com/mambenanje



On Tue, Feb 1, 2011 at 5:18 PM, Koji Sekiguchi <koji@r.email.ne.jp> wrote:

> (11/02/01 23:58), Churchill Nanje Mambe wrote:
>
>> am sorry
>>  I downloaded the solr released version as I dont know how to build solr
>> myself
>>  but I wrote my crawler with lucene 3.x
>>  now I need solr to search this index so I tried used the solr 1.4 I
>> downloaded from the site as the most recent version
>>  now I cant seem to read the index. I considered writing my own Servlet
>> RESTful API or SOAP webservice but I wish that solr can work so I dont go
>> through that stress of recreating what Solr already has
>>  so what am I to do ?
>>  do you have a higher version of solr that uses lucene 3.x ?? so I can
>> download ??
>>
>
> If I remember correctly, Lucene 2.9.4 can read Lucene 3.0 index.
> So if your index is written by Lucene 3.0 program, you can use
> Solr 1.4.1 with Lucene 2.9.4 libraries.
>
> Or simply use branch_3x, it can be downloaded by using subversion:
>
> $ svn co http://svn.apache.org/repos/asf/lucene/dev/branches/branch_3x
>
> Koji
> --
> http://www.rondhuit.com/en/
>

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message