lucene-solr-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From ankita shinde <ankitashinde...@gmail.com>
Subject solr user
Date Thu, 02 Sep 2010 06:40:37 GMT
hi,
I am able to index all my entries in my table named info. This table has
four columns named id, name, city and skill.
I have written a data-config file as follow :

<dataConfig>
  <dataSource type="JdbcDataSource"

              driver="com.mysql.jdbc.Driver"
              url="jdbc:mysql://3307/dbname"
              user="user-name"
              password="password"/>
  <document>

    <entity name="id"
            query="select id,name,city,branch from info">

<field name="id" column="id"/>
<field name="name" column="name"/>
<field name="city" column="city_t"/>
<field name="skill" column="skill_t"/>

    </entity>
  </document>
</dataConfig>




*And the entries made in schema.xml are:*

<field name="area_t" type="string" indexed="true" stored="true"/>
<field name="skill_t" type="string" indexed="true" stored="true"/>


entries for id and name are already present.


And i also have added requestimporthandler in solrconfig.xml as follow:

<requestHandler name="/dataimport"
class="org.apache.solr.handler.dataimport.DataImportHandler">
<lst name="defaults">
  <str name="config">data-config.xml</str>
</lst>
</requestHandler>



Data is successfully indexed. But I am able to find results only for
column 'name'. For other columns it is not giving result.

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message