lucene-solr-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Adam Estrada <estrada.a...@gmail.com>
Subject Importing SlashDot Data
Date Fri, 17 Sep 2010 20:11:29 GMT
All,

I have a new Windows 7 machine and have been trying to import an RSS feed
like in the SlashDot example that is included in the software. My dataConfig
file looks fine.

========================
<dataConfig>
    <dataSource type="HttpDataSource" />
    <document>
        <entity name="slashdot"
                pk="link"
                url="http://rss.slashdot.org/Slashdot/slashdot"
                processor="XPathEntityProcessor"
                forEach="/RDF/channel | /RDF/item"
                transformer="DateFormatTransformer">

            <field column="source" xpath="/RDF/channel/title"
commonField="true" />
            <field column="source-link" xpath="/RDF/channel/link"
commonField="true" />
            <field column="subject" xpath="/RDF/channel/subject"
commonField="true" />

            <field column="title" xpath="/RDF/item/title" />
            <field column="link" xpath="/RDF/item/link" />
            <field column="description" xpath="/RDF/item/description" />
            <field column="creator" xpath="/RDF/item/creator" />
            <field column="item-subject" xpath="/RDF/item/subject" />
            <field column="date" xpath="/RDF/item/date"
dateTimeFormat="yyyy-MM-dd'T'hh:mm:ss" />
            <field column="slash-department" xpath="/RDF/item/department" />
            <field column="slash-section" xpath="/RDF/item/section" />
            <field column="slash-comments" xpath="/RDF/item/comments" />
        </entity>
    </document>
</dataConfig>
======================

And when I choose to perform a full import, absolutely nothing happens. Here
is the debug code.

Sep 17, 2010 4:09:04 PM org.apache.solr.core.SolrCore execute
INFO: [rss] webapp=/solr path=/select
params={start=0&dataConfig=<dataConfig>%0d
%0a%09<dataSource+type%3D"HttpDataSource"+/>%0d%0a%09<document>%0d%0a%09%09<enti
ty+name%3D"slashdot"%0d%0a%09%09%09%09pk%3D"link"%0d%0a%09%09%09%09url%3D"http:/
/rss.slashdot.org/Slashdot/slashdot
"%0d%0a%09%09%09%09processor%3D"XPathEntityPr
ocessor"%0d%0a%09%09%09%09forEach%3D"/RDF/channel+|+/RDF/item"%0d%0a%09%09%09%09
transformer%3D"DateFormatTransformer">%0d%0a%09%09%09%09%0d%0a%09%09%09<field+co
lumn%3D"source"+xpath%3D"/RDF/channel/title"+commonField%3D"true"+/>%0d%0a%09%09
%09<field+column%3D"source-link"+xpath%3D"/RDF/channel/link"+commonField%3D"true
"+/>%0d%0a%09%09%09<field+column%3D"subject"+xpath%3D"/RDF/channel/subject"+comm
onField%3D"true"+/>%0d%0a%09%09%09%0d%0a%09%09%09<field+column%3D"title"+xpath%3
D"/RDF/item/title"+/>%0d%0a%09%09%09<field+column%3D"link"+xpath%3D"/RDF/item/li
nk"+/>%0d%0a%09%09%09<field+column%3D"description"+xpath%3D"/RDF/item/descriptio
n"+/>%0d%0a%09%09%09<field+column%3D"creator"+xpath%3D"/RDF/item/creator"+/>%0d%
0a%09%09%09<field+column%3D"item-subject"+xpath%3D"/RDF/item/subject"+/>%0d%0a%0
9%09%09<field+column%3D"date"+xpath%3D"/RDF/item/date"+dateTimeFormat%3D"yyyy-MM
-dd'T'hh:mm:ss"+/>%0d%0a%09%09%09<field+column%3D"slash-department"+xpath%3D"/RD
F/item/department"+/>%0d%0a%09%09%09<field+column%3D"slash-section"+xpath%3D"/RD
F/item/section"+/>%0d%0a%09%09%09<field+column%3D"slash-comments"+xpath%3D"/RDF/
item/comments"+/>%0d%0a%09%09</entity>%0d%0a%09</document>%0d%0a</dataConfig>%0d
%0a&verbose=on&command=full-import&debug=on&qt=/dataimport&rows=10} status=0
QTi
me=293

Can someone please explain what might be going on here? What's with all the
%0d%0a%09%09's?

Thanks in advance,
Adam

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message