lucene-solr-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Pavan Gupta <pavan....@gmail.com>
Subject Re: solr user
Date Thu, 02 Sep 2010 06:52:32 GMT
Hi Ankita,
One reason could be that you are using area_t instead of city_t for mapping.
So the association may not be taking place in Solr. Have you tried searching
on skill? That should have worked for you.
Pavan

On Thu, Sep 2, 2010 at 12:10 PM, ankita shinde <ankitashinde002@gmail.com>wrote:

> hi,
> I am able to index all my entries in my table named info. This table has
> four columns named id, name, city and skill.
> I have written a data-config file as follow :
>
> <dataConfig>
>  <dataSource type="JdbcDataSource"
>
>              driver="com.mysql.jdbc.Driver"
>              url="jdbc:mysql://3307/dbname"
>              user="user-name"
>              password="password"/>
>  <document>
>
>    <entity name="id"
>            query="select id,name,city,branch from info">
>
> <field name="id" column="id"/>
> <field name="name" column="name"/>
> <field name="city" column="city_t"/>
> <field name="skill" column="skill_t"/>
>
>    </entity>
>  </document>
> </dataConfig>
>
>
>
>
> *And the entries made in schema.xml are:*
>
> <field name="area_t" type="string" indexed="true" stored="true"/>
> <field name="skill_t" type="string" indexed="true" stored="true"/>
>
>
> entries for id and name are already present.
>
>
> And i also have added requestimporthandler in solrconfig.xml as follow:
>
> <requestHandler name="/dataimport"
> class="org.apache.solr.handler.dataimport.DataImportHandler">
> <lst name="defaults">
>  <str name="config">data-config.xml</str>
> </lst>
> </requestHandler>
>
>
>
> Data is successfully indexed. But I am able to find results only for
> column 'name'. For other columns it is not giving result.
>

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message