lucene-solr-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Chris Hostetter <hossman_luc...@fucit.org>
Subject Re: wrong lucene package in solr trunk?
Date Tue, 01 Jun 2010 22:16:14 GMT

: In order to use the current trunk version of solr, I built it running
: "ant package" in trunk/solr and added the resulting maven artifacts to
: my project.

the trunk is definitley in flux now with the way Lucene & solr (and the 
new "modules" directory) are all designed to be built as one monolithic 
release.

ultimatley it should be possible to build the individual pieces seperately 
9and to a large extent you can already do that) but it doesn't suprise me 
at all that the POMs don't make sense at the moment.

Bottom line: your best bet for right now if you want to build from source, 
is to check out hte full Lucene trunk 
(https://svn.apache.org/repos/asf/lucene/dev/trunk/) instead of just Solr, 
and build at the top level -- using all hte jars produced instead of 
trusting that any of hte POMs will be correct.  

(The simple fact is even if the POMs were correct, because it's all one 
trunk now the Solr POMs would refer to Lucene jars that don't exist in any 
repository - because they are all compiled at once)





-Hoss


Mime
View raw message