lucene-solr-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Hannes Korte <hannes.ko...@iais.fraunhofer.de>
Subject wrong lucene package in solr trunk?
Date Tue, 01 Jun 2010 14:24:57 GMT
Hi,

In order to use the current trunk version of solr, I built it running
"ant package" in trunk/solr and added the resulting maven artifacts to
my project.

Unfortunately the generated pom.xml-files contain the dependency to
lucene-*-2.9.1, but are compiled with the contents of
trunk/solr/lucene-libs.

Running solr this leads to a NoSuchMethodError in
org.apache.lucene.util.Version, because the 2.9.1 version does not
contain the valueOf-method, which is called from the current solr trunk
code.

Of course I could manually build maven artifacts from the jars contained
in lucene-libs, but this is a rather ugly solution. Does anybody know an
elegant way to handle this?

Best regards,
Hannes

Mime
View raw message