lucene-solr-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Chris Harris <rygu...@gmail.com>
Subject Re: TikaEntityProcessor on Solr 1.4?
Date Fri, 21 May 2010 21:30:47 GMT
You are right that TikaEntityProcessor has a couple of other prereqs
beyond stock Solr 1.4. I think the main point is that they're
relatively minor. I've merged TikaEntityProcessor (and some prereqs)
and its dependencies into my Solr 1.4 tree and it compiles fine,
though I haven't yet tested that TikaEntityProcessor actually works in
my setup.

Actually, rather than cherry-pick just the changes from SOLR-1358 and
SOLR-1583 what I did was to merge in all DataImportHandler-related
changes from between the 1.4 release up through Solr trunk r890679
(inclusive). I'm not sure if that's what would work best for you, but
it's one option.

On Fri, May 21, 2010 at 1:28 PM, Sixten Otto <sixten@sfko.com> wrote:
> 2010/5/19 Noble Paul നോബിള്‍  नोब्ळ् <noble.paul@gmail.com>:
>> I guess it should work because Tika Entityprocessor does not use any
>> new 1.4 APIs
>>
>> On Wed, May 19, 2010 at 1:17 AM, Sixten Otto <sixten@sfko.com> wrote:
>>> The TikaEntityProcessor class that enables DataImportHandler to
>>> process business documents was added after the release of Solr 1.4,
>>> ... Has anyone tried back-porting those changes to Solr 1.4?
>
> Did you mean "new 1.5 APIs" (since TEP was added *after* 1.4 was
> released)? Even then, that doesn't make a lot of sense to me, as at
> least a couple of new things (the binary data sources) *were* added to
> support TikaEntityProcessor.
>
> I'm sorry if I'm being dense, but I'm having trouble understanding this answer.
>
> Sixten
>

Mime
View raw message