lucene-solr-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Bill Au <bill.w...@gmail.com>
Subject Re: Snapshooter shooting after commit or optimize
Date Tue, 13 Apr 2010 17:07:51 GMT
What's the exact command you used to run snappuller and snapinstaller?  What
do you mean by

"I have set it as a option when Solr starts"

Bill

On Tue, Apr 13, 2010 at 1:01 PM, william pink <will.pink@gmail.com> wrote:

> On Mon, Apr 12, 2010 at 7:02 PM, Bill Au <bill.w.au@gmail.com> wrote:
>
> > The lines you have encloses are commented out by the <!-- and -->
> >
> > Bill
> >
> > On Mon, Apr 12, 2010 at 1:32 PM, william pink <will.pink@gmail.com>
> wrote:
> >
> > > Hi,
> > >
> > > I am running Solr 1.2 ( I will be updating in due course)
> > >
> > > I am having a few issues with doing the snapshots after a postCommit or
> > > postOptimize neither appear to work in my solrconfig.xml I have the
> > > following
> > >
> > >
> > > <!--
> > >  A postCommit event is fired after every commit or optimize command
> > >    <listener event="postCommit" class="solr.RunExecutableListener">
> > >      <str name="exe">snapshooter</str>
> > >      <str name="dir">/opt/solr/bin</str>
> > >      <bool name="wait">true</bool>
> > >      <arr name="args"> <str>arg1</str> <str>arg2</str>
</arr>
> > >      <arr name="env"> <str>MYVAR=val1</str> </arr>
> > >    </listener>
> > >
> > > -->
> > > -
> > > <!--
> > >  A postOptimize event is fired only after every optimize command,
> useful
> > >         in conjunction with index distribution to only distribute
> > optimized
> > > indicies
> > >    <listener event="postOptimize" class="solr.RunExecutableListener">
> > >      <str name="exe">snapshooter</str>
> > >      <str name="dir">/opt/solr/bin</str>
> > >      <bool name="wait">true</bool>
> > >    </listener>
> > >
> > > -->
> > >
> > > But a snapshot never gets taken, It's most likely something that I
> > haven't
> > > spotted but I can't seem to work it out. It's quite possible the route
> to
> > > snapshooter might be the issue but I have tried a few different things
> > and
> > > none have worked.
> > >
> > > Any tips appreciated,
> > >
> > > Thanks
> > >
> > > Will
> > >
> >
>
> Ahh silly me, I have removed those comments and restarted it but it still
> isn't working correctly, I have just set up snapshooter in cron though so
> it
> isn't a major problem but it would be a nice to have.
>
> I am now using snappuller and snapinstaller on the slave but I am getting
> the following error
>
> /bin/sh: solr.solr.home: No such file or directory
>
> I have set it as a option when Solr starts but I can't seem to find any
> jetty xml configs to put it in neither does the wiki tell me what file I
> require to edit so I am bit lost.
>
> Thanks again,
>
> Will
>

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message