lucene-solr-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Robert Muir <rcm...@gmail.com>
Subject Re: Trouble compiling SOLR
Date Fri, 26 Mar 2010 21:44:42 GMT
On Fri, Mar 26, 2010 at 5:35 PM, Shawn Heisey <solr@elyograg.org> wrote:
> I have checked out trunk from the new svn location that has the merged
> lucene/solr.  When I try to build it, it gets a certain distance through the
> build and spits out this:
>
> BUILD FAILED
> /opt/ncindex/src/solr/trunk/solr/common-build.xml:178: The <copy> type
> doesn't support the nested "resources" element.
>
> The only useful thing I have found relating to this suggests that I need ant
> 1.7.  Is this the case?  I really hope it isn't, because CentOS 5.4, being
> the latest version of that OS, has 1.6.5.
>
> http://www.coderanch.com/t/108791/Ant-Maven-Other-Build-Tools/copy-folders-with-ant
>
> Thanks,
> Shawn
>
>

Yes, Lucene requires ant >= 1.7.0 (see its BUILD.txt), and now Solr
does too (see its README.txt), as its trunk is in sync with Lucene's
trunk.

Its needed for a variety of purposes such as Junit4 support.

-- 
Robert Muir
rcmuir@gmail.com

Mime
View raw message