lucene-solr-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From cmose <cjm...@gmail.com>
Subject Re: Custom SearchComponent, only getting numFound back
Date Mon, 15 Feb 2010 18:23:49 GMT

A little more info. 

Doing some more digging it appears that result.getDocList().size() is
returning 0 which would explain why I'm not getting any documents in my
result. 

I'm not quite sure how/why that would be returning 0 while
result.getDocList().matches() is returning > 0?

It also looks like result.getDocListAndSet().docSet.size() is > 0... any
suggestions?


cmose wrote:
> 
> I'm attempting to write a custom SearchComponent that utilizes some custom
> filters but i'm obviously missing something key. I extend SearchComponent
> and override the prepare and process methods and then set the results on
> the result builder a la:
> 
> SolrIndexSearcher.QueryCommand cmd = rb.getQueryCommand();
> SolrIndexSearcher.QueryResult result = new
> SolrIndexSearcher.QueryResult();
> searcher.search(result, cmd);
> rb.setResult(result);
> response.add("response", builder.getREsults().docList);
> 
> 
> However, when I execute a query against the handler using this component,
> I get a empty result element e.g., 
> 
> <result name="response" numFound="300" start="0"/>
> 
> I'm not quite sure where I'm falling down here and how I'm getting a > 0
> numFound yet an empty result element...
> Thanks much
> 

-- 
View this message in context: http://old.nabble.com/Custom-SearchComponent%2C-only-getting-numFound-back-tp27596624p27597870.html
Sent from the Solr - User mailing list archive at Nabble.com.


Mime
View raw message