lucene-solr-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From javaxmlsoapdev <vika...@yahoo.com>
Subject RE: weird text stripping issue
Date Fri, 29 Jan 2010 00:37:05 GMT

Analyzers are default. anything in particular to look for?

ANKITBHATNAGAR wrote:
> 
> 
> Check you analyzers
> 
> Ankit
> 
> -----Original Message-----
> From: javaxmlsoapdev [mailto:vikasdp@yahoo.com] 
> Sent: Thursday, January 28, 2010 4:46 PM
> To: solr-user@lucene.apache.org
> Subject: weird text stripping issue
> 
> 
> I am observing very weird text stripping issue. 
> 
> when I search for word "Search" I get following 
> <doc>
>   <str name="description">Issue 18 Search String</str> 
>   <int name="key">4688</int> 
>   <str name="title">Issue 18 Search String2</str> 
>   </doc>
> 
> And highliting node
> <lst name="4688">
>   <arr name="title">
>     <str>Issue 18 Search String2</str> 
>   </arr>
>   <arr name="description">
>     <str>Issue 18 Search String</str> 
>   </arr>
> </lst>
> My actual description string is "Issue 18 Search String2" # 2 isn't coming
> up back in description attribute in my search results. note; both title &
> description are the fields solr searches against. that's how my default
> config is.
> 
> also note description is of type "clob" in my config as below.
> <field column="DESCRIPTION" name="description" clob="true"/>
> 
> however when I search on other attributes (excluding title & description)
> then returning result brings back full description text including "2". 
> 
> Any idea what's wrong going on here?
> 
> Thanks,
> -- 
> View this message in context:
> http://old.nabble.com/weird-text-stripping-issue-tp27363086p27363086.html
> Sent from the Solr - User mailing list archive at Nabble.com.
> 
> 
> 

-- 
View this message in context: http://old.nabble.com/weird-text-stripping-issue-tp27363086p27365621.html
Sent from the Solr - User mailing list archive at Nabble.com.


Mime
View raw message