lucene-solr-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Vladan Popovic <>
Subject Windows 7 / Java 64bit / solr 1.4 - solr.solr.home problem
Date Wed, 02 Dec 2009 09:17:36 GMT

I installed solr 1.4 on Windows7 64bit with Java 1.6.0_17-b04 64bit and 
I run the command:
java -Dsolr.solr.home=multicore -jar start.jar
I get the following error message:
PS C:\nginx\solr\jetty> java
-Dsolr.solr.home=c:\nginx\solr\solr\multicore -jar start.jar
Exception in thread "main" java.lang.NoClassDefFoundError:
Caused by: java.lang.ClassNotFoundException:
at$ Source)
at Method)
at Source)
at java.lang.ClassLoader.loadClass(Unknown Source)
at sun.misc.Launcher$AppClassLoader.loadClass(Unknown Source)
at java.lang.ClassLoader.loadClass(Unknown Source)
at java.lang.ClassLoader.loadClassInternal(Unknown Source)
Could not find the main class:
.solr.home=c:\nginx\solr\solr\multicore. Program will exit.

This is what I did to try to solve the problem but failed:
1. I googled quite a lot but didn't see anyone with a similar problem.
2. I tried running java in compatibility modes Vista & XP and running it
as administrator but none of it worked.
3. I installed Java 32 bit but it didn't solve the problem
4. I tested on Windows Vista 32 bit and Mac OSX snow tiger and it works 
without a problem
5. I tried to analyze the java log files on Windows 7 x64 but there was 
nothing there ...

Basically whatever home other than the default (solr/) doesn't work.
Has anyone else encountered this problem? and would anyone have a clue
how to trouble shoot

Any help would be appreciated.

Best regards


View raw message