lucene-solr-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Grant Ingersoll <gsing...@apache.org>
Subject Re: Spatial / Local Solr radius
Date Mon, 28 Dec 2009 23:02:17 GMT

On Dec 28, 2009, at 11:47 AM, Mauricio Scheffer wrote:

> q={!spatial lat=43.705 long=116.3635 radius=100}*:*

What's QParser is the "spatial" plugin? I don't know of any such QParser in Solr.  Is this
a third party tool?  If so, I'd suggest asking on that list.

> 
> with no other parameters.
> When changing the radius to 250 I get no results.
> 
> In my config I have startTier = 9 and endTier = 17 (default values)
> 
> 
> On Mon, Dec 28, 2009 at 1:24 PM, Grant Ingersoll <gsiasf@gmail.com> wrote:
> 
>> What do your queries look like?
>> 
>> On Dec 28, 2009, at 9:30 AM, Mauricio Scheffer wrote:
>> 
>>> Hi everyone,
>>> I'm getting inconsistent behavior from Spatial Solr when searching with
>>> different radii. For the same lat/long I get:
>>> 
>>> radius=1 -> 1 result
>>> radius=10 -> 0 result
>>> radius=25 -> 2 results
>>> radius=100 -> 2 results
>>> radius=250 -> 0 results
>>> 
>>> I don't understand why radius=10 and 250 return no results. Is this a
>> known
>>> bug? I'm using the default configuration as specified in the PDF.
>>> BTW I also tried LocalSolr with the same results.
>>> 
>>> Thanks
>>> Mauricio
>> 
>> 

--------------------------
Grant Ingersoll
http://www.lucidimagination.com/

Search the Lucene ecosystem using Solr/Lucene: http://www.lucidimagination.com/search


Mime
View raw message