lucene-solr-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Joel Nylund <jnyl...@yahoo.com>
Subject Re: solr/jetty not working for anything other than localhost
Date Wed, 25 Nov 2009 22:27:39 GMT
I see:

tcp46      0      0  *.8983                 *.*                     
LISTEN
tcp4       0      0  127.0.0.1.8983         *.*                     
LISTEN

thanks
Joel

On Nov 25, 2009, at 5:21 PM, simon wrote:

> first, check what port 8983 is bound to - should be listening on all
> interfaces
>
> netstat -an |grep 8983
>
> You should see
>
> tcp        0      0 0.0.0.0:8983          0.0.0.0:*                
> LISTEN
>
> -Simon
>
> On Wed, Nov 25, 2009 at 3:55 PM, Joel Nylund <jnylund@yahoo.com>  
> wrote:
>
>> Hi, if I try to use any other hostname jetty doesnt work, gives a  
>> blank
>> page, if I telnet too the server/port it just disconnects.
>>
>> I tried editing the scripts.conf to change the hostname, that didnt  
>> seem to
>> help.
>>
>> For example I tried editing my etc/hosts file and added:
>>
>> 127.0.0.1 solriscool
>>
>> then:
>> ping solriscool
>> PING solriscool (127.0.0.1): 56 data bytes
>> 64 bytes from 127.0.0.1: icmp_seq=0 ttl=64 time=0.055 ms
>> 64 bytes from 127.0.0.1: icmp_seq=1 ttl=64 time=0.095 ms
>>
>>
>> sh-3.2# telnet solriscool 8983
>> Trying 127.0.0.1...
>> Connected to solriscool.
>> Escape character is '^]'.
>> GET / HTTP/1.1
>> Connection closed by foreign host.
>>
>>
>> telnet localhost 8983
>> Trying ::1...
>> Connected to localhost.
>> Escape character is '^]'.
>> GET /solr HTTP/1.1
>> Host: localhost
>>
>> HTTP/1.1 302 Found
>> Location: http://localhost/solr/
>> Content-Length: 0
>> Server: Jetty(6.1.3)
>>
>>
>> any ideas?
>>
>> thanks
>> Joel
>>
>>


Mime
View raw message