lucene-solr-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Fergus McMenemie <fer...@twig.me.uk>
Subject Re: Error when indexing XML files
Date Fri, 16 Oct 2009 06:35:19 GMT
Hi,

Please find the schema file attached. Please let me know what I am doing wrong.

Regards
Chaitali

--- On Wed, 10/14/09, Fergus McMenemie <fergus@twig.me.uk> wrote:


From: Fergus McMenemie <fergus@twig.me.uk>
Subject: Re: Error when indexing XML files
To: solr-user@lucene.apache.org
Date: Wednesday, October 14, 2009, 2:25 AM

>Hi,
>
>I am trying to index XML files using SolrJ. The original XML file contains nested elements.
For example, the following is the snippet of the XML file.
>
><entry>
> <name>SOMETHING </name>
> <facility>SOME_OTHER_THING</facility>
> </entry>
>
>I have added the elements "name" and "facility" in Schema.xml file to make these elements
indexable. I have changed the XML document above to look like -
>
><add>
><doc>
> ......
> <field name="name">SOMETHING</field>
> ......
></doc>
></add>
>
Can you send us the Schema.xml file you created? I suspect that
one of the fields should be multivalued.



   <field name="facility" type="string" indexed="true" stored="true"/>
   <field name="name" type="text" indexed="true" stored="true"/>

one or other, perhaps both your fields need to be

   <field name="facility" type="string" indexed="true" stored="true" multiValued="true"/>
   <field name="name" type="text" indexed="true" stored="true" multiValued="true"/>



-- 
Fergus.

Mime
View raw message