lucene-solr-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Yonik Seeley <yo...@lucidimagination.com>
Subject Re: Incorrect sort with with function query in query parameters
Date Tue, 19 May 2009 00:35:50 GMT
This was fixed April 24th
https://issues.apache.org/jira/browse/SOLR-1124
  explained further in
https://issues.apache.org/jira/browse/SOLR-1111

-Yonik
http://www.lucidimagination.com

On Thu, Mar 26, 2009 at 10:24 PM, Asif Rahman <asif@newscred.com> wrote:
>
> Hi all,
>
> I'm having an issue with the order of my results when attempting to sort by
> a function in my query.  Looking at the debug output of the query, the score
> returned with in the result section for any given document does not match
> the score in the debug output.  It turns out that if I optimize the index,
> then the results are sorted correctly.  The scores in the debug output are
> the correct scores.  This behavior only occurs using a recent nightly build
> of Solr.  It works correctly in Solr 1.3.
>
> An example query is:
>
> http://localhost:8080/solr/core-01/select?qt=standard&fl=*,score&rows=10&q=*:*%20_val_:"recip(rord(article_published_at),1,1000,1000)"^10000&debugQuery=on
>
> I've attached the result to this email.
>
> Can anybody shed any light on this problem?
>
> Thanks,
>
> Asif
> http://www.nabble.com/file/p22735009/result.xml result.xml
> --
> View this message in context: http://www.nabble.com/Incorrect-sort-with-with-function-query-in-query-parameters-tp22735009p22735009.html
> Sent from the Solr - User mailing list archive at Nabble.com.
>
>

Mime
View raw message