lucene-solr-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Ron Chan <rc...@i-tao.com>
Subject Re: numFound problem
Date Wed, 21 Jan 2009 20:57:32 GMT
I'm using out of the box Solr 1.3 that I had just downloaded, so I guess it is the StandardAnalyzer


but shouldn't the returned docs equal numFound? 


----- Original Message ----- 
From: "Erick Erickson" <erickerickson@gmail.com> 
To: solr-user@lucene.apache.org 
Sent: Wednesday, 21 January, 2009 20:49:56 GMT +00:00 GMT Britain, Ireland, Portugal 
Subject: Re: numFound problem 

It depends (tm). What analyzer are you using when indexing? 

I'd expect (though I haven't checked) that StandardAnalyzer 
would break SD/DDeck into two tokens, SD and DDeck which 
corresponds nicely with what you're reporting. 

Other analyzers and/or filters are easy to specify.... 

I'd recommend getting a copy of Luke and examining your 
index to see what's actually in it.... 

Best 
Erick 

On Wed, Jan 21, 2009 at 3:43 PM, Ron Chan <rchan@i-tao.com> wrote: 

> I have a test search which I know should return 34 docs and it does 
> 
> however, numFound says 40 
> 
> with debug enabled, I can see the 40 it has found 
> 
> my search looks for "SD DDeck" in the description 
> 
> 34 of them had "SD DDeck" with 6 of them having "SD/DDeck" 
> 
> now, I can probably work round it if had returned me the 40 docs but the 
> problem is it returns 34 docs but gives me a numFound of 40 
> 
> is this expected behavior? 
> 
> 
> 

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message