lucene-solr-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Mark Ferguson <mark.a.fergu...@gmail.com>
Subject Re: solr.core.name property not available on core creation
Date Mon, 26 Jan 2009 19:28:03 GMT
Thanks Shalin. Any ideas on a workaround in the mean time? I suppose I could
set the instanceDir property to the data directory rather than the common
directory, then set the config and schema explicitly.

Mark

On Mon, Jan 26, 2009 at 12:16 PM, Shalin Shekhar Mangar <
shalinmangar@gmail.com> wrote:

> This is a known issue. I'll try to give a patch soon.
>
> https://issues.apache.org/jira/browse/SOLR-883
>
> On Mon, Jan 26, 2009 at 11:59 PM, Mark Ferguson
> <mark.a.ferguson@gmail.com>wrote:
>
> > Hi,
> >
> > I am trying to set up a multi-core environment in which I share a single
> > conf folder. I am following the instructions described in this thread:
> > http://www.mail-archive.com/solr-user@lucene.apache.org/msg16954.html
> >
> > In solrconfig.xml, I am setting dataDir to /srv/solr/cores/data/${
> > solr.core.name}.
> >
> > It works well when using existing cores, but when I try to create a core
> > dynamically via the core admin web interface, it gives me an error
> message:
> >
> > HTTP Status 500 - No system property or default value specified for
> > solr.core.name
> >
> > To create the core I am entering the following url:
> >
> >
> http://localhost:8080/solrcore/admin/cores?action=CREATE&name=p5&instanceDir=
> > .
> >
> > Any suggestions?
> >
> > Mark
> >
>
>
>
> --
> Regards,
> Shalin Shekhar Mangar.
>

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message