lucene-solr-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Feak, Todd" <Todd.F...@smss.sony.com>
Subject RE: Issue with Search when using wildcard(*) in search term.
Date Tue, 09 Dec 2008 16:21:20 GMT
I'm pretty sure "*" isn't supported by DisMax.

>From the Solr Wiki on DisMaxRequestHandler overview

http://wiki.apache.org/solr/DisMaxRequestHandler?highlight=(dismax)#head
-ce5517b6c702a55af5cc14a2c284dbd9f18a18c2

"This query handler supports an extremely simplified subset of the
Lucene QueryParser syntax. Quotes can be used to group phrases, and +/-
can be used to denote mandatory and optional clauses ... but all other
Lucene query parser special characters are escaped to simplify the user
experience......"

-Todd Feak

-----Original Message-----
From: payalsharma [mailto:payalsharma7@yahoo.com] 
Sent: Tuesday, December 09, 2008 4:51 AM
To: solr-user@lucene.apache.org
Subject: Issue with Search when using wildcard(*) in search term.


Hi All,

I am searching a term on Solr by using wildcard character "*" like this
:
    
http://delpearsonwebapps:8080/apache-solr-1.3.0/core510000043/select/?q=
alle*

here the search term(word) is : alle*
This query gives me proper result , but as i give dismaxrequest as
parameter
in the query , no results are returned , query with dismax parameter
goes
like this :

http://delpearsonwebapps:8080/apache-solr-1.3.0/core510000043/select/?q=
alle*&qt=dismaxrequest


Can anybody let me know the reason behind this behavior, also do I need
to
make any changes in my SolrConfig.XML  in order to make the query run
with
both Wildcard as well as dismaxrequest.

Thanks in advance.

Payal
-- 
View this message in context:
http://www.nabble.com/Issue-with-Search-when-using-wildcard%28*%29-in-se
arch-term.-tp20914102p20914102.html
Sent from the Solr - User mailing list archive at Nabble.com.



Mime
View raw message