lucene-solr-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Ryan McKinley <ryan...@gmail.com>
Subject Re: Solr JSP compilation error
Date Mon, 08 Dec 2008 16:02:14 GMT
I think your best option is to edit the jsp and remove that syntax...

So you are not running 1.5?  how does anything else work?!



On Dec 8, 2008, at 10:12 AM, Sorbo wrote:

>
> Yes everything works except the JSPs. The errors are with the Java  
> 1.5 syntax
> viz with the index.jsp
> it doesn't like the Java 1.5 syntax
> for( org.apache.solr.core.SolrCore core : cores.getCores() ) {%>
> This is the stack trace
> org.apache.jasper.JasperException: Unable to compile class for JSP
>
> An error occurred at line: 30 in the jsp file: /index.jsp
> Generated servlet error:
> Syntax error on token ":", ; expected
>
> An error occurred at line: 30 in the jsp file: /index.jsp
> Generated servlet error:
> Syntax error on token ")", ; expected after this token
>
>
>
> ryantxu wrote:
>>
>> what is the error?
>> Does everything work except the jsp?
>>
>>
>> On Dec 7, 2008, at 11:53 PM, Sorbo wrote:
>>
>>>
>>> Hi,
>>> I'm using Solr 1.3 with Tomcat 5.5.9 and getting JSP compilation
>>> errors with
>>> the Java 1.5 syntax in the admin JSP pages. I cannot upgrade to  
>>> higher
>>> version of Tomcat at the moment. What are my options?
>>>
>>> Thanks for your time,
>>> Sorbo
>>>
>>>
>>> -- 
>>> View this message in context:
>>> http://www.nabble.com/Solr-JSP-compilation-error-tp20889505p20889505.html
>>> Sent from the Solr - User mailing list archive at Nabble.com.
>>>
>>
>>
>>
>
> -- 
> View this message in context: http://www.nabble.com/Solr-JSP-compilation-error-tp20889505p20897077.html
> Sent from the Solr - User mailing list archive at Nabble.com.
>


Mime
View raw message