lucene-solr-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Erick Erickson" <erickerick...@gmail.com>
Subject Re: Retrieving a non-indexed but stored field
Date Wed, 05 Nov 2008 19:23:02 GMT
What's the query you're hitting SOLR with? If it's on the URL field,
that would match your behavior.... I.e. if you're getting
results based upon whether you index the field or not,  it
would be neatly explained by whether you're *searching* on
that field.

Best
Erick@AShotInTheDark....

P.S. Luke might help here too....


On Wed, Nov 5, 2008 at 2:09 PM, Andrew Nagy <andrew.nagy@villanova.edu>wrote:

> Nope - I made the schema change and then indexed all of my content.
>
> I can confirm that the URL string is included, cause when I change my
> schema back to have both stored and indexed, it shows the URL data in the
> search results.  When I change it to stored and not indexed, no data is
> returned.
>
> Andrew
> ________________________________________
> From: yseeley@gmail.com [yseeley@gmail.com] On Behalf Of Yonik Seeley [
> yonik@apache.org]
> Sent: Wednesday, November 05, 2008 1:41 PM
> To: solr-user@lucene.apache.org
> Subject: Re: Retrieving a non-indexed but stored field
>
> On Wed, Nov 5, 2008 at 11:47 AM, Andrew Nagy <andrew.nagy@villanova.edu>
> wrote:
> > Sorry for the late follow-up.  I am doing this, but get nothing back.
>
> Did you change the field to "stored" in the schema after you added the
> document?
> I've never seen anyone having this problem, so perhaps verify that you
> are actually sending the url field when indexing.
>
> -Yonik
>

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message