lucene-solr-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Andrew Nagy <andrew.n...@villanova.edu>
Subject RE: SpellCheckComponent problems (was: Multiple search components in one handler - ie spellchecker)
Date Mon, 28 Jul 2008 16:20:00 GMT
Hmm ... sorry, that was the output of a java program that uses solr that I ran and noticed
the error.  That error doesn't happen when I start solr.  Sorry for the confusion.

I just changed my schema to have a dedicated field for spelling called "spelling" and I created
a new field type for the spellcheck component called "textSpell".
Here is the segment of my solrconfig.xml:

<searchComponent name="spellcheck" class="org.apache.solr.handler.component.SpellCheckComponent">
  <lst name="spellchecker">
    <str name="field">spelling</str>
    <str name="accuracy">0.7</str> <!-- 0.5 is the default setting -->
    <str name="spellcheckIndexDir">./spellchecker</str>
  </lst>
  <str name="queryAnalyzerFieldType">textSpell</str>
</searchComponent>
<queryConverter name="queryConverter" class="org.apache.solr.spelling.SpellingQueryConverter"/>
<requestHandler name="/search" class="org.apache.solr.handler.component.SearchHandler">
  <lst name="defaults">
    <str name="echoParams">explicit</str>
  </lst>
  <arr name="last-components">
    <str>spellcheck</str>
    <!--<str>elevator</str>-->
  </arr>
</requestHandler>

I will need to reindex my documents again - I will check to see if that has any effect on
my problem.

Andrew


> -----Original Message-----
> From: Shalin Shekhar Mangar [mailto:shalinmangar@gmail.com]
> Sent: Monday, July 28, 2008 12:07 PM
> To: solr-user@lucene.apache.org
> Subject: Re: SpellCheckComponent problems (was: Multiple search
> components in one handler - ie spellchecker)
>
> No, SpellCheckComponent was in the nightly long before July 25. There
> must
> be a stack trace after that error message. Can you post that?
>
> On Mon, Jul 28, 2008 at 9:26 PM, Andrew Nagy
> <andrew.nagy@villanova.edu>wrote:
>
> > I was just reviewing the solr logs and I noticed the following:
> >
> > Jul 28, 2008 11:52:01 AM org.apache.solr.common.SolrException log
> > SEVERE: org.apache.solr.common.SolrException: Error loading class
> > 'org.apache.solr.handler.component.SpellCheckComponent'
> >
> > It looks like the SpellCheckComponent is not getting loaded.  What
> could
> > cause this?  Im running the july25 nightly build.
> >
> > Here is a list of the libs from my /tmp/jetty/webapp/WEB-INF/lib dir:
> > -rw-r--r--  1 root root  84199 Jul 25 08:14 apache-solr-common-
> nightly.jar
> > -rw-r--r--  1 root root 889903 Jul 25 08:14 apache-solr-nightly.jar
> > -rw-r--r--  1 root root  46725 May 10  2007 commons-codec-1.3.jar
> > -rw-r--r--  1 root root  22017 Jan  6  2008
> > commons-csv-1.0-SNAPSHOT-r609327.jar
> > -rw-r--r--  1 root root  53082 Mar  1  2007 commons-fileupload-
> 1.2.jar
> > -rw-r--r--  1 root root 305001 Sep 11  2007 commons-httpclient-
> 3.1.jar
> > -rw-r--r--  1 root root  83613 Jun 15  2007 commons-io-1.3.1.jar
> > -rw-r--r--  1 root root  38015 Jun 14  2007 commons-logging-1.0.4.jar
> > -rw-r--r--  1 root root 249154 Sep 21  2007 junit-4.3.jar
> > -rw-r--r--  1 root root 115101 Jun 19 13:46 lucene-analyzers-2.4-
> dev.jar
> > -rw-r--r--  1 root root 730352 Jun 19 13:46 lucene-core-2.4-dev.jar
> > -rw-r--r--  1 root root  87390 Jun 19 13:46 lucene-highlighter-2.4-
> dev.jar
> > -rw-r--r--  1 root root  32693 Jun 19 13:46 lucene-queries-2.4-
> dev.jar
> > -rw-r--r--  1 root root  91029 Jun 19 13:46 lucene-snowball-2.4-
> dev.jar
> > -rw-r--r--  1 root root  18422 Jun 19 13:46 lucene-spellchecker-2.4-
> dev.jar
> > -rw-r--r--  1 root root 179348 Jun 14  2007 stax-1.2.0-dev.jar
> > -rw-r--r--  1 root root  25863 Jun 14  2007 stax-api-1.0.jar
> > -rw-r--r--  1 root root 128475 Jun 14  2007 stax-utils.jar
> >
> > could I be missing a jar?
> >
> > Thanks
> > Andrew
> >
> > > -----Original Message-----
> > > From: Shalin Shekhar Mangar [mailto:shalinmangar@gmail.com]
> > > Sent: Monday, July 28, 2008 11:24 AM
> > > To: solr-user@lucene.apache.org
> > > Subject: Re: SpellCheckComponent problems (was: Multiple search
> > > components in one handler - ie spellchecker)
> > >
> > > Hi Andrew,
> > >
> > > Your configuration which you specified in the earlier thread looks
> > > fine.
> > > Your query is also ok. The complete lack of spell check results in
> the
> > > response you pasted suggests that the SpellCheckComponent is not
> added
> > > to
> > > the SearchHandler's list of components.
> > >
> > > Can you check your solrconfig.xml again? I'm sorry but it doesn't
> seem
> > > like
> > > a problem with the spell checker itself. Also check if there are
> any
> > > exceptions in the Solr log/console.
> > >
> > > On Mon, Jul 28, 2008 at 8:32 PM, Andrew Nagy
> > > <andrew.nagy@villanova.edu>wrote:
> > >
> > > > > -----Original Message-----
> > > > > From: Shalin Shekhar Mangar [mailto:shalinmangar@gmail.com]
> > > > > Sent: Monday, July 28, 2008 10:09 AM
> > > > > To: solr-user@lucene.apache.org
> > > > > Subject: Re: SpellCheckComponent problems (was: Multiple search
> > > > > components in one handler - ie spellchecker)
> > > > >
> > > > > Can you show us the query you are issuing? Make sure you add
> > > > > spellcheck=true
> > > > > to the query as a parameter to turn on spell checking.
> > > >
> > > >
> > > >
> > >
> http://localhost:8080/solr/select?q=*:*&spellcheck=true&spellcheck.q=sc
> > > andanava&spellcheck.build=true
> > > >
> > > > Shows this:
> > > > <response>
> > > > <lst name="responseHeader">
> > > > <int name="status">0</int>
> > > > <int name="QTime">73</int>
> > > > </lst>
> > > > <result name="response" numFound="7650" start="0">
> > > > ...
> > > > </result>
> > > > </response>
> > > >
> > > > Andrew
> > > >
> > >
> > >
> > >
> > > --
> > > Regards,
> > > Shalin Shekhar Mangar.
> >
>
>
>
> --
> Regards,
> Shalin Shekhar Mangar.

Mime
View raw message