lucene-solr-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Noble Paul നോബിള്‍ नोब्ळ्" <noble.p...@gmail.com>
Subject Re: Can't get wild card search to work against data from DataImporter
Date Sat, 24 May 2008 15:55:47 GMT
It does not have any obvious problems. You must probably run it
through the query analyzer .
Using DIH for indexing should not make any difference .
--Noble

On Sat, May 24, 2008 at 11:11 AM, Julio Castillo
<jcastillo@edgenuity.com> wrote:
> I have a simple test schema
> That has users with the following columns:
>  id
>  first_name
>  last_name
>
> I added the following two fields into the schema.xml
>   <field name="firstName"  type="text" indexed="true"  stored="true"/>
>   <field name="lastName" type="text" indexed="true"    stored="true"/>
>
> I added the following query in my data-config.xml
> <dataConfig>
>  <document name="test">
>    <entity name="owners" pk="id"
>            query="select * from owners"
>            deltaQuery="SELECT id FROM owners WHERE last_modified >
> '${dataimporter.last_index_time}'">
>        <field column="id"              name="id"/>
>        <field column="first_name"      name="firstName"/>
>        <field column="last_name"       name="lastName"/>
>    </entity>
>  </document>
> </dataConfig>
>
> I then execute a dataimport.
> Using the admin window I type in the search
>
> firstName:Jeff
>
> And I get a response (per my data).
>
> But typing
>  J?ff
> Or
>  firstName:J?ff
>
> Gets no returns. What else do I need to do to make wild cards search
> working?
>
> Julio Castillo
> Edgenuity Inc.
>
>



-- 
--Noble Paul

Mime
View raw message