lucene-solr-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "李银松" <leongf...@gmail.com>
Subject problem with ShowFileRequestHandler
Date Wed, 02 Apr 2008 09:03:43 GMT
Edward.Zhang had commit the problem before

> I want to programmatically retrieve the schema and the config from the
> ShowFileRequestHandler.  I encounter some trouble. There are CJK
characters
> in the xml files as follows:
>
>
> >  <!-- Field to use to determine and enforce document uniqueness.
> >       Unless this field is marked with required="false", it will be a
> > required field
> >    -->
> >  <uniqueKey>记录号</uniqueKey>
> >
>
> But I get a confusing response from solr using "/admin/file/?file=
> schema.xml". IE and firefox both report parse errors.I try
> "/admin/file/?file=schema.x&contentType=text/plain" and I get the same
> result as follow:
>
>
> >  <!-- Field to use to determine and enforce document uniqueness.
> >       Unless this field is marked with required="false", it will be a
> > required field
> >    -->
> >  <uniqueKey>?????/uniqueKey>
>
>
> BTW: The xml files are encoded in UTF-8 and they work fine when I open
> these files locally using IE. And I set tomcat's 8080 connector
> "URIEncoding" argument "UTF-8" too.
> So is there anything missing for me? Or is it a bug?
>
> Every reply would be appreciated.

Ryan  has changed the RawResponseWriter to use the Reader
but problem seems not solved
For example:
my schema.xml is a "UTF-8" File
but reader's default encoding is "GBK"
then i still can't get the right String
Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message