lucene-solr-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From nithyavembu <nithyave...@yahoo.co.in>
Subject Re: Search result not coming for normal special characters...
Date Mon, 11 Feb 2008 17:03:28 GMT

Thanks Erick.

I have tried with WhitespaceAnalyzer as you said.

-> In my schema.xml i have removed the filter class
"solr.WordDelimiterFilterFactory" for both indexing and querying.

-> If i remove this, the special character search works fine. But i am
unable to search for this scenario...

 example : indexData : sriHari, sweetHeart,mike Oliver

 SearchData: 

             If i search for sri, sweet,mike or oliver it returns the search
result correctly. But if i search for
"Hari","Heart" its not returning the result. In the middle of the term if i
give any word i am unable to search.
-> I found that in "solr.WordDelimiterFilterFactory" will split the word and
provides the middle of word search. But special character ignored here. 
        
-> I need the both the scenarios to work. Is it possible? Any idea or
solution? 
 
Thanks,
Nithya.




When in doubt, use WhitespaceAnalyzer and build up from there. It's the
simplest. Look at the Lucene docs for what the various analyzers do
under the covers.

Note: WhitespaceAnalyzer does NOT transform to lowercase, you have
to do that yourself or compose your own analyzer.....

Erick


-- 
View this message in context: http://www.nabble.com/Search-with-the-characters-%28%21%2C%40%2C-%2C%24%2C-%2C%5E%2C-%2C*%2C%28%2C%29%2C%7B%2C%7D%2C-%2C-%29...-tp15339827p15415375.html
Sent from the Solr - User mailing list archive at Nabble.com.


Mime
View raw message