lucene-solr-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Keene, David" <>
Subject RE: question about bi-gram analysis on query
Date Sat, 06 Oct 2007 07:46:38 GMT
Hi Otis!

Yes, I've run the query though debugQuery=yes.  I posted the difference between the debug
output and the Luke parsed query in my original post.  here's a snippet:

Also, I've noticed that the parsed query on luke is:
text:"美聯 聯社"
and in solr it is:
text:"美聯 聯社 "
I noticed there is an extra space in the solr parsed query.  I don't know if that makes a

Like I said, the space in there is the only difference between my parsed query in Luke and
the debug query output .  I even stepped though the response in solr with eclipse, and confirmed
that the parsed query was tokenenized properly (bigram), but had that extra space in there.

On the analysis page, I see hits come up in the text fine, but nothing on a search from the
main page.


-----Original Message-----
From: Otis Gospodnetic [] 
Sent: Friday, October 05, 2007 11:51 PM
Subject: Re: question about bi-gram analysis on query


Have you tried using ....&debugQuery=true ? :)

 . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .
Simpy --  -  Tag  -  Search  -  Share

----- Original Message ----
From: "Keene, David" <>
To: Teruhiko Kurosaka <>
Sent: Thursday, October 4, 2007 4:44:59 PM
Subject: RE: question about bi-gram analysis on query


Thanks for responding.  I should have been clearer..

By "actual search" I meant hitting the search demo page on the solr admin page.  So I get
no results on this query:


But the same query (with the data in my index) on the analysis page shows me a hit (and the
same search in Luke gets me a hit too).

I've tried this on 1.1, 1.2 and nightly as of yesterday. I assume that I am missing something
really obvious..


-----Original Message-----
From: Teruhiko Kurosaka [] 
Sent: Thursday, October 04, 2007 12:44 PM
To: Keene, David
Subject: RE: question about bi-gram analysis on query

Hello David,
> And if I do a search in Luke and the solr analysis page 
> for美聯, I get a hit.  But on the actual search, I don't.

I think you need to tell us what you mean by "actual search"
and your code that interfaces with Solr.


View raw message