lucene-solr-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Spencer Tickner" <spencertick...@gmail.com>
Subject Re: HTTP response code: 400 error
Date Tue, 19 Jun 2007 18:33:32 GMT
Hi Guys,

Thanks very much for the response. Brian you were correct. I was
following a separate tutorial where the fields had been added to the
schema.

Cheers,

Spencer

On 6/19/07, Yonik Seeley <yonik@apache.org> wrote:
> On 6/19/07, Brian Whitman <brian.whitman@variogr.am> wrote:
> >
> > > Hi List,
> > >
> > > Thanks in advance for the help. I'm new to Solr and ran across a bit
> > > of a problem. I installed Solr with the Jetty and tested the
> > > exampledocs. Everything went great. Next I tried adding one of my own
> > > documents to the collection. The XML is below:
> > >
> > Are you running the example without changing the schema? The example
> > schema doesn't have all of those fields. If you look at your Jetty
> > log, you'll see the real error, which is
> >
> > Jun 19, 2007 2:02:04 PM org.apache.solr.common.SolrException log
> > SEVERE: org.apache.solr.common.SolrException: ERROR:unknown field
> > 'title'
> >
> > It's probably a Solr bug that the post.jar does not return a useful
> > error message
>
> Or a Java bug?
> http://www.innovation.ch/java/HTTPClient/urlcon_vs_httpclient.html
> I'm not sure if it's possible to get the extra info with Java's
> built-in HTTP client.
>
> Spencer, does post.sh give you more error info?
>
> -Yonik
>

Mime
View raw message