lucene-solr-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Chris Hostetter <hossman_luc...@fucit.org>
Subject Re: replication test problems
Date Mon, 30 Oct 2006 23:54:41 GMT

: Here's a problem I got. It says there's no match for snapshot.* found on the
: master box. This is wrong, there's one such file exists.
:
: - I then ran snappuller specifically on the snap file that's on the master:
:   ./bin/snappuller -n snapshot.20061023172655
:
: This time it worked. and  running installer created the index successfully.

It's possible that there may be a subtle bug in the logic for determining
hte latest snapshot on your OS, the relevent section of of snappuller
is...

 # get directory name of latest snapshot if not specified on command line
 if [[ -z ${snap_name} ]]
 then
     snap_name=`ssh -o StrictHostKeyChecking=no ${master_host} "find ${master_data_dir} -name
snapshot.* -print"|grep -v wip|sort -r|head -1`
 fi

...which OS are you running this on?

: 2. when I ran snappuller, it kept asking me for passwords for at least three
: four time. Is this because it's using SSH? I have sudo permission on the
: master box. This makes me think if it's a cron-job that calls up the
: snappuller, how does the cron deal with this password prompts?

to run in a cron, you would need to set up ssh keys for the uid the crons
will run as which have empty passphrases (so they can function without a
passphrase prompt).

Another posisble reason why the snappuller failed for you the first time,
is if you accidently misstyped your passphrase one of the times it asked
you (it's not snapppuller asking you this, snappller is just executing
ssh, and ssh is asking you directly) ... one of those times was the code
snippet i included above, which makes an ssh call just to get the name of
hte most recent snapshot.


-Hoss


Mime
View raw message