lucene-solr-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Grant Ingersoll (JIRA)" <j...@apache.org>
Subject [jira] Updated: (SOLR-1849) ant luke target in Solr build no longer works
Date Fri, 26 Mar 2010 21:22:27 GMT

     [ https://issues.apache.org/jira/browse/SOLR-1849?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

Grant Ingersoll updated SOLR-1849:
----------------------------------

    Description: 
Here's a fix:
{code}
<property  name="luke.version" value="1.0.0"/>
  <available file="luke/luke-${luke.version}.jar" property="luke.jar.exists" />
  <target name="luke-download" unless="luke.jar.exists" depends="proxy.setup">
    <mkdir dir="luke"/>
    <get src="http://luke.googlecode.com/files/luke-${luke.version}.jar"
        dest="luke/luke-${luke.version}.jar"/>
  </target>
  
  <target name="luke" depends="luke-download">
    <java fork="true" 
          classname="org.getopt.luke.Luke"
          logError="true"
          failonerror="true">
      <classpath>
        <fileset dir="luke">
          <include name="luke-${luke.version}.jar"/>
        </fileset>
        <path refid="lucene.classpath"/>
        <path refid="test.run.classpath"/>
       </classpath>
    </java>
  </target>
{code}

But it requires there to be a standalone, downloadable version of Luke w/o any Lucene bundled
in.

  was:
Here's a fix:
{code}
<property  name="luke.version" value="1.0.0"/>
  <available file="luke/luke-${luke.version}.jar" property="luke.jar.exists" />
  <target name="luke-download" unless="luke.jar.exists" depends="proxy.setup">
    <mkdir dir="luke"/>
    <get src="http://luke.googlecode.com/files/lukeall-${luke.version}.jar"
        dest="luke/luke-${luke.version}.jar"/>
  </target>
  
  <target name="luke" depends="luke-download">
    <java fork="true" 
          classname="org.getopt.luke.Luke"
          logError="true"
          failonerror="true">
      <classpath>
        <fileset dir="luke">
          <include name="luke-${luke.version}.jar"/>
        </fileset>
        <path refid="lucene.classpath"/>
        <path refid="test.run.classpath"/>
       </classpath>
    </java>
  </target>
{code}

But it requires there to be a standalone, downloadable version of Luke w/o any Lucene bundled
in.


> ant luke target in Solr build no longer works
> ---------------------------------------------
>
>                 Key: SOLR-1849
>                 URL: https://issues.apache.org/jira/browse/SOLR-1849
>             Project: Solr
>          Issue Type: Bug
>            Reporter: Grant Ingersoll
>            Priority: Trivial
>
> Here's a fix:
> {code}
> <property  name="luke.version" value="1.0.0"/>
>   <available file="luke/luke-${luke.version}.jar" property="luke.jar.exists" />
>   <target name="luke-download" unless="luke.jar.exists" depends="proxy.setup">
>     <mkdir dir="luke"/>
>     <get src="http://luke.googlecode.com/files/luke-${luke.version}.jar"
>         dest="luke/luke-${luke.version}.jar"/>
>   </target>
>   
>   <target name="luke" depends="luke-download">
>     <java fork="true" 
>           classname="org.getopt.luke.Luke"
>           logError="true"
>           failonerror="true">
>       <classpath>
>         <fileset dir="luke">
>           <include name="luke-${luke.version}.jar"/>
>         </fileset>
>         <path refid="lucene.classpath"/>
>         <path refid="test.run.classpath"/>
>        </classpath>
>     </java>
>   </target>
> {code}
> But it requires there to be a standalone, downloadable version of Luke w/o any Lucene
bundled in.

-- 
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.


Mime
View raw message