lucene-solr-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Yonik Seeley <>
Date Thu, 14 Jan 2010 17:17:33 GMT
The current way of allowing the omission of a core name in the URL is
to name the core DEFAULT_CORE.
While this functionality is great, and allows a multi-core setup to be
back compat with existing URLs, if someone does want to also refer to
the core by it's proper name, it looks pretty ugly.  This also impacts
SolrCloud, since the core name is used as the collection name by
default (and a collection name of DEFAULT_CORE is... ugly).

So I'd propose that we either:
1) allow an optional flag in solr.xml to mark that any core is also
the default core
2) rename DEFAULT_CORE to something nicer like "collection1"

It seems like #1 would be preferable... thoughts?


View raw message